none
Change paper size to legal RRS feed

  • Question

  • I'm using report designer and want to default the paper size to legal. I can set the page size, I also changed the paper to legal in the page setup dialogue box but still no success. I've also been reading other posts that suggest using inches but I've already set it that way, I also tried changing to pts. How do I do this without writing code?

    Friday, September 7, 2007 12:15 AM

Answers

  • Yes I think you are setting the size right in the RDL properties (I don't much care what preview tells you <s>).

     

    You should be able to confirm what you see in the modal Report Properties dialog in the PageSize properties value for report in the Properties window, btw.

     

    >> you are probably correct that it is the defaults for the printer

     

    The best thing to do here is to set up a separate printer setup for the same printer -- label it Canon ir LegalSize or something -- with the papersize set the way you want.  Then choose this printer setup when you go to print...

     

    >L<

     

    Tuesday, September 11, 2007 6:00 PM

All replies

  •  

    >>default the paper size to legal.

     

    Are you saying that it doesn't work when you make your layout changes?  Or do you really mean you want to change the *defaults* with which the report designer comes up, for additional reports?

     

    If the latter, the best way I know to do this is to set up a report template with your base or default and then use that one (with Save As) for future report sessions.

     

    If the former, tell us exactly what you did regarding the page layout changes ...?

     

    >L<

     

    Monday, September 10, 2007 4:28 PM
  • It doesn't work when I make my layout changes.  I just want to change a single report. Within the report that I have created, I can change the page size and the sheet size. When I'm on the preview tab I can also change the paper size via the page set up dialogue box however, once i view the report and go to print, there is a default that is overriding the settings and prints the report on letter.

     

    I'd be happy to create a new template and change all of the defaults and have say a letter template and a legal template but even starting from scratch I can't get the paper to change from letter.

     

    Thanks for any help that you can give.

    V

    Monday, September 10, 2007 10:09 PM
  • >>

    it doesn't work when I make my layout changes... I can also change the paper size

    <<

     

    I asked what exactly you did to make your layout changes.  There are several things that you might mean.  I wanted to make sure you were changing Page Size and not Interactive Page Size.

     

    I do have a couple of other questions for you:

     

    * -- what does Print Layout show you (in terms of paper size)?

     

    * -- when you go to print, the default for the printer driver might also be involved.  So what is your printer driver in this case, and how are its defaults/preferences set?

     

    * -- is this using the Reporting Services client print control that the problem shows up, or are you in a winforms reportcontrol, or what?

     

    >L<

     

    Monday, September 10, 2007 10:52 PM
  • I changed the page size under report properties to be 8.5in & 14in

    On the preview tab, I clicked on page setup and changed the paper size to legal (it's a drop down)

    When I do a print preview from within the preview tab, it shows it on letter size, it is the same if I export the report into a PDF, or when I run the report through reporting services.

    I'm printing to a network printer - it is my default. The printer, Canon iR C5800, is set to Auto select the paper.

     

    From what I've said above, am I setting the paper size correctly in VS? If so, you are probably correct that it is the defaults for the printer.

     

    Thanks, V

    Tuesday, September 11, 2007 5:02 PM
  • Yes I think you are setting the size right in the RDL properties (I don't much care what preview tells you <s>).

     

    You should be able to confirm what you see in the modal Report Properties dialog in the PageSize properties value for report in the Properties window, btw.

     

    >> you are probably correct that it is the defaults for the printer

     

    The best thing to do here is to set up a separate printer setup for the same printer -- label it Canon ir LegalSize or something -- with the papersize set the way you want.  Then choose this printer setup when you go to print...

     

    >L<

     

    Tuesday, September 11, 2007 6:00 PM