none
Error while running the get-app command RRS feed

  • Question

  • Hello Members,

    We have recently installed Exchange 2016 CU11 in our environment and it is coexisting with exchange 2010. Everything works fine with exchange but I keep getting this error in exchange management shell when run get-app command.

    [PS] C:\Windows\system32>Get-App
    Exchange Server doesn't support the requested version.
        + CategoryInfo          : InvalidOperation: (:) [Get-App], OwaExtensionOperationException
        + FullyQualifiedErrorId : [Server=XXXXXXXXXXXX,RequestId=85337632-41c0-4c0b-b03e-eca37963955e,TimeStamp=14/02/2
       019 10:37:09] [FailureCategory=Cmdlet-OwaExtensionOperationException] FDAE7038,Microsoft.Exchange.Management.Exten
      sion.GetApp
        + PSComputerName        : XXXXXXXXXXXXXXXXXXXXXXXXXX

    If I login to Exchange admin center and go to Organization --> addins I get the same error Exchange Server doesn't support the requested version.

    Tried a lot to look for that error on internet and got very few cases and none of the apply to my scenario

    > I am not running exchange Managed webservices API 2.2

    > My Arbitration are moved to EXG 2016

    Any pointers to sort this out would be appreciated


    Rahul Katiyar

    Friday, February 15, 2019 8:14 AM

All replies

  • Hello Members,

    We have recently installed Exchange 2016 CU11 in our environment and it is coexisting with exchange 2010. Everything works fine with exchange but I keep getting this error in exchange management shell when run get-app command.

    [PS] C:\Windows\system32>Get-App
    Exchange Server doesn't support the requested version.
        + CategoryInfo          : InvalidOperation: (:) [Get-App], OwaExtensionOperationException
        + FullyQualifiedErrorId : [Server=XXXXXXXXXXXX,RequestId=85337632-41c0-4c0b-b03e-eca37963955e,TimeStamp=14/02/2
       019 10:37:09] [FailureCategory=Cmdlet-OwaExtensionOperationException] FDAE7038,Microsoft.Exchange.Management.Exten
      sion.GetApp
        + PSComputerName        : XXXXXXXXXXXXXXXXXXXXXXXXXX

    If I login to Exchange admin center and go to Organization --> addins I get the same error Exchange Server doesn't support the requested version.

    Tried a lot to look for that error on internet and got very few cases and none of the apply to my scenario

    > I am not running exchange Managed webservices API 2.2

    > My Arbitration are moved to EXG 2016

    Any pointers to sort this out would be appreciated


    Rahul Katiyar

    • Merged by Manu Meng Wednesday, February 20, 2019 8:01 AM duplicated thread
    Thursday, February 14, 2019 6:28 PM
  • Hi Rahulkrims,

    Based on my searching, this issue may related with EWS, such as this thread. I would suggest you post in at Exchange Server Development forum,  because users in that forum are better at EWS issues.

    I can also help you move this post to that forum.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, February 15, 2019 5:56 AM
  • Thank you Kyle,

    I will post my question to the development forum as well


    Rahul Katiyar

    Friday, February 15, 2019 8:15 AM