locked
SQL Server Reporting Services 2008 R2 RRS feed

  • Question

  • Hello,

    I have just installed SQL Server 2008 R2 on WIndows Vista Home Premium. I can log in to  Management Studio Database Engine, Analysis Service and Integration Services with Windows Authentication and i can also use BI Dev Studio. Though I cannot deploy reports in report server i cannot log in to Reporting Services throigh Management Studio and i cannot enter the report server throgh IE (i have tried http://localhost/reports, http:/localhost:80/reports http://localhost:8080/reportserver etc but i get the page cannot display. When installing i had set a common username and pssw for all applications. I have read in a forum that i might need to manipulate the rporting serrvices configuration manager but i don't know how.

    Any help is greatly appreciated

    Thanks in advance

    Andreas

    Wednesday, May 11, 2011 11:03 AM

Answers

  • Hi,

    Ideally, if you are the Adminstrator, you should be able to access the Report Manager. But as a workaround please log on to your machine using the 'Administrator' account and you should be able to access the Report Manager. Now on the 'Home' page click on 'Properties' and add your 'Andreas-PC\Andreas' account as 'Content Manager'. Hope this helps.


    MSBI Developer
    • Proposed as answer by Elvis Long Monday, May 16, 2011 1:30 AM
    • Marked as answer by Tony Chain Thursday, May 19, 2011 12:47 PM
    Thursday, May 12, 2011 8:21 AM

All replies

  • Hi,

    Is reporting services configured during installation or did you select 'Install but do not configure' option, during installation?


    MSBI Developer
    Wednesday, May 11, 2011 11:18 AM
  • Hello,

    Thanks for replying. To be honest i do not remember. Biut i think i chose the default options while installing.

     

    Thanks.

    Wednesday, May 11, 2011 11:27 AM
  • Hi,

    Go to Start-->All Programs-->Microsoft SQL Server 2008-->Configuration Tools-->Reporting Services Configuration Manager. Here  you can see the 'Database' that your report server is connected to , web service URL and Report Manager Url. Click on one of those urls' and see if they work. Else please provide the details.


    MSBI Developer
    Wednesday, May 11, 2011 11:33 AM
  • Hello Andreas,

    Start menu => Microsoft SQL Server 2008 R2 => Configuration Tools => Reporting-Services Configuration

    Check in that tool if all configurations are done & valid.

    Which Edition did you install and is it a standard or named instance? If e.g. it's Express Edition then it's a named instance "SQLEXPRESS" by default =>  http://localhost/reports_SQLEXPRESS


    Olaf Helper
    * cogito ergo sum * errare humanum est * quote erat demonstrandum *
    Wenn ich denke, ist das ein Fehler und das beweise ich täglich
    Blog Xing
    Wednesday, May 11, 2011 11:34 AM
  • Hello,

    The report server url is http://andreas-pc:80/reportserver --> The web page cannot be found

    The report manager url is http://andreas-pc:80/reports --> The web page cannot be found

     

    Thanks again

     

     

    Wednesday, May 11, 2011 11:45 AM
  • Hi Andrikos,

    Did you check what "Olaf Helper" & "TDPN" have replied you in their earlier post?

    Please go to below note and give us your feedback:-

    Start menu => Microsoft SQL Server 2008 R2 => Configuration Tools => Reporting-Services Configuration
    
    Check in that tool if all configurations are done & valid.
    
    

     

    Thanks

    Kumar


    KG, MCTS
    Wednesday, May 11, 2011 12:05 PM
  • Hi,

    Please check :

    1)If your 'SQL Server Reporting Services' service is started

    2)If your User account is a local Admin

    Also go through the below discussion on same topic and see if this helps.

    http://social.msdn.microsoft.com/Forums/en/sqlexpress/thread/75910bcb-a879-4eb7-9757-acc45201fa3a


    MSBI Developer
    Wednesday, May 11, 2011 12:20 PM
  • Hello,

    Thanks for the replies. I changed the port from 80 to 8080 in the web service url and report manager url in reporting services configuration manager. When i enter the link http:/localhost:8080/reports i get the reporting services page with the following message: Reporting Servise: Error User 'Andreas-PC\Andreas' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.

     

    Andreas is the admininstrator on the computer. What should i do?

    Thanks

    Wednesday, May 11, 2011 5:39 PM
  • Hi,

    Please run Internet Explorer(IE) as Administrator to fix the issue.

    Yes. This issue is caused by UAC. In Windows 7, IE run under user privileges, which is not enough for accessing Report Server.

    You could find more information about this issue from: http://msdn.microsoft.com/en-us/library/bb630430.aspx

    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/541b73cc-10d7-47ba-9743-86ae5cbb2854

    Please let us know your feedback.

    Thanks

    Kumar


    KG, MCTS
    Wednesday, May 11, 2011 6:07 PM
  • Hello,

     

    I run IE as administrator but i get the same message

     

    Thanks

    Wednesday, May 11, 2011 6:28 PM
  • Hello,

     

    I run IE as administrator but i get the same message

     

    Thanks

    Wednesday, May 11, 2011 6:28 PM
  • Hi,

    Ideally, if you are the Adminstrator, you should be able to access the Report Manager. But as a workaround please log on to your machine using the 'Administrator' account and you should be able to access the Report Manager. Now on the 'Home' page click on 'Properties' and add your 'Andreas-PC\Andreas' account as 'Content Manager'. Hope this helps.


    MSBI Developer
    • Proposed as answer by Elvis Long Monday, May 16, 2011 1:30 AM
    • Marked as answer by Tony Chain Thursday, May 19, 2011 12:47 PM
    Thursday, May 12, 2011 8:21 AM