locked
CSS problems after Windows 10 Pro Update RRS feed

  • Question

  • User1103166301 posted

    Hi

    I'm running Windows 10 Pro, version 1809 (17763.503). I'm converting an old Classic asp site to a .Net C# Razor site. Consequently, I need access to the old asp site to review functionality before recoding it. I have built the Classic asp site on my development laptop and all has been running well for years now. The site is running in production at a few clients and also on my demo web site which is hosted by my ISP. All sites are working except the development site on my laptop running Windows 10 Pro.

    The problem (for those not wanting to read my thesis below):  After implementing the Windows update my Classic ASP site stopped rendering Bootstrap 3 (and 4) style sheets and images. No errors are displayed, just the web site's text, links and controls are displayed without any styling.  All database work is unaffected and working.

    Some weeks ago (24 April to be exact) Windows prompted me to install an upgrade which I duly did - to version 1809 (17763.503). The upgrade went smoothly but immediately afterwards I noticed that the old Classic asp site on my dev laptop stopped working in Edge, IE11, FF or Chrome. Specifically, it was taking 30 seconds or more to open the site, not rendering the css (I use a version of Bootstrap 3 called Smarty which I purchased for its themes) and when it eventually displays the home page, on clicking the link to navigate to the log in page, that page fails to load. No real coding error is ever displayed except that the page normally says something like "The page cannot be displayed" and "ERR_CONNECTION_RESET" or "INET_E_DOWNLOAD FAILURE", depending on the browser. All is OK with the database connection and data calls etc. so its not a database error or connection error.

    I contacted Microsoft Help Desk and after being handed over through 5 different consultants (I'm bald now from tearing my hear out) and hours of watching them fiddle here and there on my laptop, they couldn't explain it so they just arrogantly ended it all by saying they've tested their software extensively and are satisfied that it is working and therefore the problem must lie with my application. I don't buy it because minutes before I applied the Windows upgrade my Classic asp app was working in ALL browsers, and just minutes after the upgrade it was failing in ALL browsers. The cynic in me says that Microsoft has deliberately started introducing changes that will culminate in them stopping support for Classic ASP and this is their way of forcing change. Incidentally, the new Razor site is running with the same Bootstrap and database and is running well.

    Event viewer reports this error in "System" but I can't seem to see what triggers it throughout the day and I don't know it it's related. I tried one suggestion to change the permissions on the APPID but that didn't change anything: The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {8E240CF7-3017-494D-877D-7D19548A3142} and APPID {F72671A9-012C-4725-9D2F-2A4D32D65169} to the user ACER\hende SID (S-1-5-21-1995079702-3253873399-167814391-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    So what else have I tried?

    • Tweaking various browser settings, deleting the cached files & cookies etc.
    • * Tweaking various settings in IIS; deleting the web site and recreating it.
    • * Adding more features for "Internet Information Service" in "Turn Windows features on and off" in the hope that this would trigger some change to IIS on Windows 10 Pro. * Creating a new user with Admin rights.
    • * Running sfc /scannow. No errors were reported.
    • * Running DISM /Online /Cleanup-Image / RestoreHealth. No errors were reported.
    • * Downloading a fresh version of Windows 10 Pro iso and re-installing Windows.
    • * Flushing the DNS.
    • * Tested using other laptops running on Windows 10 and Windows 2008 Server, connecting via my local network to my development site, both work correctly using all browsers.
    • * Tested the production site of the Classic ASP app, which is published on the Internet (same code and database as I'm running on my development laptop), using my laptop and the others metioned above, and all work correctly. My conclusion therefore is that the problem doesn't lie with the browsers, or the Classic asp app's code or the css, but with the Windows 10 Pro OS that's failing to render style sheets correctly when served from the local ISS (localhost) to browsers on the local PC.
    • * If I exclude all FIVE links to css sheets in the app it responds and loads as quickly as normal (without styling of course).
    • * I created a new 1-page Classic asp test app/site to emulate the app's css link to the same relative css folder location as the Bootstrap css, but with a simple custom-made style sheet with one property in it, and database connection. The test app worked correctly.
    • * I then linked the test app to the FIVE Bootstrap css style sheets that the production app uses. The test app fails to render the css.
    • * I ran all the Bootstap style sheets through W3School's CSS Validation Service and fixed all reported errors. The error still persisted thereafter.
    • * I eliminated reference to all but the main style sheet and then placed a single custom css property at the very top so that I could see it rendered in the test app, and then deleted all other 8000 odd rows of the style sheet. No error was found. My custom property was visible and rendered correctly.
    • * I then incrementally added 100 rows of Bootstrap css code back and tested after each. Initially the error didn't occur, but after reaching around 2600 rows the error started occurring, but not consistently, so I was never able to actually pinpoint a specific css property that was causing the error. Even after rolling back 300 or more rows, the error persisted, despite the fact that it had previously worked with 2300 rows of css code. So this wasn't a reliable indicator at all. As a result, after hours of back and forth testing I gave up with this.
    • * I installed a new clean version of the Bootstrap 3 and then the Bootstrap 4 css product from the vendor, but the problem still remains. My conclusion, Windows 10 Pro version 1809 (17763.503), has a bug that prevents it from serving complex, long, multi-page, style sheets to browsers on the local PC. Surely I can't be the only one in the world to be experiencing this?
    • Any help will be greatly appreciated.
    Thursday, May 23, 2019 7:51 AM

All replies

  • User-2114649853 posted

    Hi TawandaL,

    According to your description, I suggest that you should disable Enhanced Protected Mode in IE on Windows 10,I think after you update the windows, it has enable this option for your internet for security,However it will restrict the content in website ,like css style or some scripts.So I think this is why css style couldn't be displayed.

    To disable this .you could open IE browser and Click Settings in the top right corner.You could see as below:

    Best Regards

    Able

    Friday, May 24, 2019 5:55 AM
  • User1103166301 posted

    Hello Able

    Thanks for the suggestion.  Sadly, I've have already tried that and that was one of the first things every Microsoft "Help desk consultant" tried - without success - even though every other consultant had already tried it as well (They're like little robots, doing the same thing over and over).

    Anyway, this morning I downloaded and ran "Fiddler". It is reporting http 504 errors (Gateway error) with exactly the css and js files that are causing the error.  Specifically it says: "[Fiddler] ReadResponse() failed: The server did not return a complete response for this request. Server returned 0 bytes".  The problem is I don't know yet how to interpret the results of Fiddler or how to troubleshoot further, but I suppose I find some help on the Internet going forward - I just have to find the time!  These programs always amaze me - there's lots of help on how to configure and run the program, but NOTHING on how to interpret the results of the program's execution or on how to possibly resolve the errors.  Thanks again.

    Friday, May 24, 2019 7:41 AM
  • User-1877864849 posted

    Hi,

    This may be a touch off topic because it is not entirely IIS related, but I have just read this and I am experiencing VERY similar issues. Mine did not kick in until September update 1903 but with very similar effect.  Here is my scenario:

    I was running a Nginx/MariaDB/PHP development environment on my Windows 10 m/c with a copy deployed n a Linux machine (same server stack).  Everything was working fine in the morning.  I set update 1903 to install over lunch and when I came back my development site was not working. After much heartache and hair loss I have tracked it down to the fact that .css and .js files are not getting served if their size is >10Kb (small ones are OK). Here is a quick summary of what I have tried since:

    1) Reinstalled the same server stack with latest versions

    2) Installed instead an Apache stack

    3) As I had been doing some editing and not wanting to upset my working (Linux) copy, I installed an Apache setup on another Linux m/c and everything worked fine.

    4) I tried IIS but despite installing PHP by the Microsoft recommended route (MS WPI), I have been unable to get PHP to work with IIS

    So if either a) anyone has any helpful hints to getting PHP working with IIS so that I can test it properly or b) there was a resolution found to Tawandal's problem then I would very much like to hear.

    Thanks

    Tuesday, October 8, 2019 4:07 PM
  • User1103166301 posted

    Hi Norman

    Sorry to hear about your problem.  I was only able to resolve it by completely reinstalling the OS and of course all my other software.  The cost to me, not just financially, but in many other ways was enormous, but of course Microsoft continues to rake in the billions from their flawed software and is totally and utterly unconcerned, indeed I would say deliberately so in order to avoid the legal and financial consequences.

    I still live in fear of it happening again with every update they release, as Bill Gates, his successors and their gang of merry wo/men sip on their sundowners.

    Wednesday, October 9, 2019 4:40 AM
  • User1140981189 posted

    hi TawandaL

    I purchased a new laptop with windows 10 OS to replace my old windows 7 laptop of 10 years service

    I am now back to square one struggling to reuse the old laptop just

    three weeks after purchasing the new

    all was running smoothly in windows 10 S mode

    with auto updates running in the back ground

    I thought i would be safe as I am not an expert on these things 

    but I will never trust auto updates again

    my new laptop will no longer connect to the internet and is left unused until further notice etc

    it just tells me the XML page can not be displayed can not view XML input using XSL style sheet (script code) etc

    which is confusing to me rolled the laptop back to out of the box factory settings made no difference 

    am in the same boat

    Wednesday, May 6, 2020 3:09 PM
  • User-1732050945 posted

    I found that the styles worked in IE as soon as I changed web.config to debug="false".
    So, the problem only occurred on my new Windows 10 development PC with compilation debug true, even using Start without debugging. There was no such issue on my old Windows 7 PC.

    This is where I found a fix for the problem: https://stackoverflow.com/questions/16030905/enable-bundling-and-minification-in-debug-mode-in-asp-net-mvc-4

    In short, add BundleTable.EnableOptimizations = true; to your BundleConfig. Why we need to do this, I don't know, but it works.

    Thursday, May 28, 2020 3:54 AM