locked
WebPart not viewable to one user RRS feed

  • Question

  • there is one user who cannot view a webpart on a sharepoint site.

    I tried logging in with her A.D. credentials on my computer/browser and I am not able to view the webpart.

    I can view it fine when I'm logged in as myself.

    I created a new A.D. test account , which is a copy of her account, and she is able to view the webpart successfully when she logs in with this test account on her computer/browser.

    Any ideas what would cause this? 

    Her account and the test account both have the same permissions in A.D. and SharePoint.

    Could an A.D. account become corrupt in some way that would affect viewing webparts on sharepoint?

    thanks!

    Tuesday, March 1, 2016 5:21 PM

Answers

  • Hi lorrdellatorre,

    Check if other operations could work well except the web part when using the problematic user.

    Please try to remove the user from the SharePoint site, and re-add it again. Then test again, compare the result.

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Victoria Xia Thursday, March 10, 2016 9:14 AM
    • Marked as answer by Pratik Vyas Wednesday, March 16, 2016 2:10 AM
    Monday, March 7, 2016 8:45 AM

All replies

  • Does that webpart have 'audience targeting enabled'?

    This might help you http://sharepointviews.com/hidden-users-list-in-sharepoint/ if there is any issue with user permission cache

    Tuesday, March 1, 2016 7:43 PM
  • Hi lorrdellatorre,

    I agreed with Bharath, please edit the web part and check if you enable "Target Audiences".

    Check if other operations could work well except the web part when using the problematic user.

    Please try to remove the user from the SharePoint site, and re-add it again. Then test again, compare the result.

    Thanks,

    Wendy 


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, March 3, 2016 7:04 AM
  • No, Target Audiences is not being used.
    Thursday, March 3, 2016 12:58 PM
  • Hi lorrdellatorre,

    Check if other operations could work well except the web part when using the problematic user.

    Please try to remove the user from the SharePoint site, and re-add it again. Then test again, compare the result.

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Victoria Xia Thursday, March 10, 2016 9:14 AM
    • Marked as answer by Pratik Vyas Wednesday, March 16, 2016 2:10 AM
    Monday, March 7, 2016 8:45 AM
  • Hello,

    Maybe the user setup a personal page? I mean he edit the page and he's not on the default one?

    Thursday, March 10, 2016 9:04 AM