none
Printer installation with "printui.exe /ia" results in error "The arguments are invalid" RRS feed

  • Question



  •  I try to install a printer with it's INF file using the tool "printui.exe" (which seems to be equivalent to "rundll32 printui.dll,PrintUIEntry" but is just shorter to write). Goal is a "Windows 10 64-bit" system in a VMWare VirtualMachine.
     I actually want to do the installation with the INF file of my own driver but because this didn't work I instead tried to exercise the installation with the "bitmap" sample of the WDK 10
    ("C:\Program Files (x86)\Windows Kits\8.1\Testing\Samples\OEM Printer Customization Plug-in Samples\C++\bitmap.inf").

     So I produced the 64-bit bitmap.dll and created a directory with those files:
    bitmap.dll
    bitmap.gpd
    bitmap.inf
    bitmap.ini
     And because I don't know exactly where the DLL has to be positioned I also created two subdirs:
    amd64\bitmap.dll
    bitmap\amd64\bitmap.dll

     To run the printui.exe I started a CMD.EXE with "Administrator" privileges and there I called the commands... the first try was:
    >>>
    printui.exe /ia /f bitmap.inf /h amd64 /v "Type 3 - User Mode"
    printui.exe /if /f bitmap.inf /r "NUL:"
    <<<
     Two additional notes:
    - the "NUL:" port has been created before and exists
    - the second call to printui.exe is of course obsolete until the first call succeeds

     The result of the first call is a messagebox with a highly detailed problem explanation: "The arguments are invalid" (because I have a German Windows the text is "Die Argumente sind ungültig").
     After that first anti-success I have tried to vary the commandline options in a dozens of ways but the result is ALWAYS: "The arguments are invalid"
     And because I have NO ideas any more I would now like to ask the community: "Where is the problem?"

    Many thanks in advance for any suspicion and excessive thanks for the solution
     greetings, sporxix
    Thursday, July 28, 2016 3:28 PM