locked
IIS Serves blank page RRS feed

  • Question

  • User-54634383 posted

    Having a bit of trouble with our IIS server in that it was intermittently throwing a 403 error stating that IIS didn't have permission to a website's resources. We've since set the default document to for the website and now it just returns a blank page when ever requesting .ASPX files. .HTML and .JPG files can be accessed when this occurs.<o:p></o:p>

    This issue appears to happen when ever the application pool automatically recycles. There are multiple application running on the same pool but only one or two get effected by this problem. On some occasions there is also an issue that an website using another application pool gets effected.

    So far the only thing that solves this problem is manually recycling the application pool.<o:p></o:p>

    We are running Windows Web Server 2008, IIS 7, .NET 4 with 1900 application in the pool.<o:p></o:p>

    Any help would be greatly appreciated.<o:p></o:p>

    Friday, June 27, 2014 4:55 AM

Answers

  • User-37275327 posted

    Did you try reregistering ASP.NET with IIS?
    on the cmd, aspnet_regiis -i

    Make sure that site folders has read permission. 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 27, 2014 6:13 AM
  • User-1454326058 posted

    Hi Rapido_XS,

    First, please refer to cnranasinghe’s reply.

    Secondly, which authentication type that you used? If you are using windows authentication, please disable anonymous authentication. If you are using forms authentication, please check the setting in the web.config. (loginURL)

    On the other hand, the authentication tickets would be lose during the application pool recycling.

    For this issue, I could post it to the IIS forum for efficient response.

    Thanks

    Best Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, June 30, 2014 2:31 AM

All replies

  • User-37275327 posted

    Did you try reregistering ASP.NET with IIS?
    on the cmd, aspnet_regiis -i

    Make sure that site folders has read permission. 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 27, 2014 6:13 AM
  • User-1454326058 posted

    Hi Rapido_XS,

    First, please refer to cnranasinghe’s reply.

    Secondly, which authentication type that you used? If you are using windows authentication, please disable anonymous authentication. If you are using forms authentication, please check the setting in the web.config. (loginURL)

    On the other hand, the authentication tickets would be lose during the application pool recycling.

    For this issue, I could post it to the IIS forum for efficient response.

    Thanks

    Best Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, June 30, 2014 2:31 AM