none
docm file is continually being checked for problems and saving doesn't work properly RRS feed

  • Question

  • I hope my english is well enough for you to understand me ..
    I have a problem with saving .docm files : this takes really a long time.

    I think I found the reason but have no idea how to solve this :

    When the file is opened and I choose left above "file", a field is shown with 3 items : "document beveiligen" "controleren op problemen" en "versies beheren" ( I'm sorry but I don't know how to translate this properly ). I see that in the second option ( check for problems ) the document is being checked for problems continually : the circle keeps on running here. I think that's the reason for saving soooo slowly...

    I can only save the document by choosing "close document" ( the cross right above ). Then I get the question if I want to save the file. When I choose "yes" it's saving very quickly. 

    Can anyone tell me what's wrong and how to solve this ? I'm a little bit of a dummy in this sort of things, so I hope an eventually solution can be explained clearly for me.

    Thanks in advance !

    

    That means, when I click on 

    Tuesday, December 19, 2017 3:46 PM

Answers

  • Hello Deepak,

    I just took another look in Google and guess what : this is a link (https://answers.microsoft.com/en-us/office/forum/office_2013_release-word/word-2013-extremely-slow-saving-and-pasting-plain/94718ebd-0a1a-4542-904a-33185a115ae2?page=3) to a thread from 5 YEARS AGO where this issue had a simple solution : turn off background saving. I realise this might be a "dangerous" solution but for me it finally works.

    There's also a fix from Microsoft in that thread, but I don't trust myself to change things in the register, so I'll stick to disable background saving. This is the fix :

    Note: The method to fix the issue will have Registry modification. Before you modify the Registry, make sure to back it up and understand how to restore the registry if a problem occurs.

    Using Regedit, go to this registry key address:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Excel\Security\FileValidation

    Or

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Word\Security\FileValidation

    Double click the REG_DWORD: EnableOnLoad, set its value to 0 (zero) and restart the PC.

    If you do not have the ~\Office\15.0\Excel (or Word)\Security\FileValidation, you can create it:


    Most of the other user's same cases, this Registry method worked. To some, it improved the save time consumption.

    Since we need to Consider the Overall System Performance, please perform this method as well:

    1. In Search tab of the Start menu, type "Adjust the appearance and performance of windows" and pressEnter

    2. Go to Advanced tab and click Change... button in the Virtual memory section

    3. At the top, uncheck the box right before "Automatically manage paging file size for all drives"option.

    4. Select drive C: (or the drive where Windows 10 is installed).

    5. Select Custom size: by ticking its radio button, and change the Initial size (MB) and Maximum size (MB) to the Recommended value that you will find just below; on the Total paging file size for all drivers section.

    This method will help improve the system performance.

    Remember: Changing the Paging file size into larger than which was recommended by Windows is not going to be helpful.

    Lastly, depending on which Protection Software you have, please temporarily tweak its scan policy. For Document scanning, make sure to check that it is not scanning the entire documents that are saved (or being saved), for it will be a little harsh in the system. Contact your Antivirus Software support line in order to do this.

    I just wonder why this issue seems to be unknown to you ( read Microsoft ) ???? I really spent a lot of time to search for a solution and being very irritated because of the saving which was soooooo slowly.... 


    • Marked as answer by Hanneke R Monday, January 8, 2018 3:19 PM
    • Edited by Hanneke R Monday, January 8, 2018 6:37 PM aanvulling
    Monday, January 8, 2018 3:04 PM

All replies

  • Hi Hanneke R,

    does your file executes any code when you try to close the file?

    do I know what kind of processing or automation you are doing in this document.

    it is helpful for us to find the issue.

    from that, we can decide that whether the issue is related with your Word Application or it is related with this specific document.

    did you try to open and save this same document from any other machine?

    if yes, does the issue persist there?

    if you did not test that then I suggest you to make a test.

    if possible for you then you can remove all the sensitive and confidential information from your document and try to share dummy sample document here then we can reproduce the issue.

    you can inform us , which Word version you are using. we will make attest with your document to find the root cause for this issue.

    further you can try to save this document in .docx format to check whether the same issue is there or not.

    please try to provide above mentioned information.

    we will try to provide you further suggestions to solve the issue.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, December 20, 2017 3:12 AM
    Moderator
  • Hi Hanneke R,

    is your issue solved?

    I find that you did not follow up this thread after posting the issue.

    if your issue is solved then I suggest you to post your solution and mark it as an answer.

    if your issue is still exist then try to refer the solution given by the me.

    if then also you have any further questions then let me know about it.

    I will try to provide further suggestions to solve the issue.

    Thanks for your understanding.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, December 27, 2017 9:08 AM
    Moderator
  • Hi Deepak,

    Sorry for my late reaction, but I didn't get a notification that my question had been answered. I'm very busy at this moment but will check your reply a.s.a.p. !

    Thursday, January 4, 2018 3:22 PM
  • Hi Hanneke R,

    you can make a test when you have a free time.

    then you can share your testing result with us.

    we will try to provide you further suggestions to solve the issue.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 5, 2018 8:44 AM
    Moderator
  • Hello Deepak,

    I just took another look in Google and guess what : this is a link (https://answers.microsoft.com/en-us/office/forum/office_2013_release-word/word-2013-extremely-slow-saving-and-pasting-plain/94718ebd-0a1a-4542-904a-33185a115ae2?page=3) to a thread from 5 YEARS AGO where this issue had a simple solution : turn off background saving. I realise this might be a "dangerous" solution but for me it finally works.

    There's also a fix from Microsoft in that thread, but I don't trust myself to change things in the register, so I'll stick to disable background saving. This is the fix :

    Note: The method to fix the issue will have Registry modification. Before you modify the Registry, make sure to back it up and understand how to restore the registry if a problem occurs.

    Using Regedit, go to this registry key address:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Excel\Security\FileValidation

    Or

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Word\Security\FileValidation

    Double click the REG_DWORD: EnableOnLoad, set its value to 0 (zero) and restart the PC.

    If you do not have the ~\Office\15.0\Excel (or Word)\Security\FileValidation, you can create it:


    Most of the other user's same cases, this Registry method worked. To some, it improved the save time consumption.

    Since we need to Consider the Overall System Performance, please perform this method as well:

    1. In Search tab of the Start menu, type "Adjust the appearance and performance of windows" and pressEnter

    2. Go to Advanced tab and click Change... button in the Virtual memory section

    3. At the top, uncheck the box right before "Automatically manage paging file size for all drives"option.

    4. Select drive C: (or the drive where Windows 10 is installed).

    5. Select Custom size: by ticking its radio button, and change the Initial size (MB) and Maximum size (MB) to the Recommended value that you will find just below; on the Total paging file size for all drivers section.

    This method will help improve the system performance.

    Remember: Changing the Paging file size into larger than which was recommended by Windows is not going to be helpful.

    Lastly, depending on which Protection Software you have, please temporarily tweak its scan policy. For Document scanning, make sure to check that it is not scanning the entire documents that are saved (or being saved), for it will be a little harsh in the system. Contact your Antivirus Software support line in order to do this.

    I just wonder why this issue seems to be unknown to you ( read Microsoft ) ???? I really spent a lot of time to search for a solution and being very irritated because of the saving which was soooooo slowly.... 


    • Marked as answer by Hanneke R Monday, January 8, 2018 3:19 PM
    • Edited by Hanneke R Monday, January 8, 2018 6:37 PM aanvulling
    Monday, January 8, 2018 3:04 PM