locked
Unable to activate Windows Tailored Application

    Question

  • I was happily coding along and suddenly started getting this message. Other apps continue to be able to be debugged, etc., from VS, but the app I'm working on has somehow become corrupt. Reboot didn't help. How can I uncorrupt it?

     

    Thursday, September 22, 2011 10:09 PM

Answers

  • I just ended up creating a new project, migrating the files and I was good to go.
    Tuesday, September 27, 2011 10:52 PM

All replies

  • Can you share the full error message (other than the app name).  Was there anything in the VS output window (i.e., like a DEP00XXX message)?
    Tim Heuer | Program Manager, XAML | http://timheuer.com/blog | @timheuer
    Thursday, September 22, 2011 10:22 PM
  • This seems to do with the Package Family Name as listed in the appxmanifest. Is there a way to change/reset that?
    Thursday, September 22, 2011 10:23 PM
  • Yes, if you open up the manifest, change the Package Identity Name.  This tells me that you have an app installed already with that same identity and perhaps under another user or was previously installed via another mechanism.

    But changing the package identity name in the manifest editor should get you around that.


    Tim Heuer | Program Manager, XAML | http://timheuer.com/blog | @timheuer
    Thursday, September 22, 2011 10:26 PM
  • Nope, no error messages other than the message box that says Unable to activate Windows Tailored Application and then has the package family name. I renamed the package and still no love. :(
    Monday, September 26, 2011 5:13 PM
  • I just ended up creating a new project, migrating the files and I was good to go.
    Tuesday, September 27, 2011 10:52 PM
  • I've observed this error in a Metro style app I'm working on today. I started rebuilding the project step-by-step, and I observed that I started getting the "Unable to activate Windows Tailored application" error after adding a second XAML resource dictionary. I first added the light_generic.xaml file from the samples, and all was still fine. 

    As soon as I added a second XAML resources file, in this case one of my own with nothing but some solid color brush definitions, I started getting this error. I.e. now my App.xaml file has two entries in its ResourceDictionary.MergedDictionaries tag. 

    If I remove the second file from the project, the error does NOT stop happening. I've tried changing the Package Name field in the manifest, but that doesn't help. Looks like I need to rebuild the project from scratch again. 

    There are no errors written to the output error - the app just displays the splash screen and hangs. Other than adding the resource files and changing the images, it's a bog-standard wizard-generated blank application. 

    UPDATE: And, I pushed my luck too far -- after rebuilding the project, adding light_generic.xaml (this time as the *only* added resource dictionary file) caused the error again. And again, can't seem to get a workaround. This is one extremely frustrating IDE bug. 
    • Edited by Adam Alpern Thursday, September 29, 2011 1:01 AM
    Wednesday, September 28, 2011 11:16 PM
  • I am getting the same error "Unable to activate Windows Tailored application", operation not supported. Unknown error 0x80270232.
    This is after I create a new default application from VS. I tried the basic as well as the split type, with the same error. The error happens after F5 -> Deploy Succeeded

    C# or C++ project made no change in the outcome

     


    Unmesh
    Friday, September 30, 2011 2:58 PM
  • @Unmesh - please ensure your screen resolution is at least 1024x768 and reply back.
    Tim Heuer | Program Manager, XAML | http://timheuer.com/blog | @timheuer
    Friday, September 30, 2011 4:42 PM
  • Even I got the same issue, the resolution shows as 1280 X 1024, still I am getting the issue.
    Monday, October 3, 2011 8:25 AM
  • I'm getting exactly the same problem with a newly created C# Metro-style application created with the "Application" template. The only additional information with the error message is: "The remote procedure call failed." There are no error messages in the Output window, just a message indicating that the program exited with code -1073741819 (0xc0000005).

    I've tried rebooting and I've tried changing the GUID for the Package Name in Package.appxmanifest, but neither of those has made a difference. My screen resolution is 1280x800, so meets the minimum spec. Another application that I've created using the same template works fine.

    Similar to the problem described above, I do have two additional resource dictionaries in the project.

    Thursday, October 6, 2011 10:54 AM
  • I assume by 2 resource dictionaries, you are including them like this:

     

    <Application.Resources>
      <ResourceDictionary>
        <ResourceDictionary.MergedDictionaries>
          <ResourceDictionary Source="MainSkin.xaml">
          <ResourceDictionary Source="LightSkin.xaml">
        </ResourceDictionary.MergedDictionaries>
      </ResourceDictionary>
    
    

    I created a Split Application C# type and absolutely have not touched the package manifest in any way. MainSkin is all of the resources the split app creates and LightSkin is from the ApplicationData sample just to make sure there is data. Using a ResourceDictionary in App.xaml.cs means you're only given that very first entry and you have to then merge all the rest. It's easily possible that something can screw up in this merge process but I would think you would see a different error.

    I've only seen "Unable to activate Windows Tailored application" when I've screwed something up in the package manifest. For instance, setting the "Lock Screen Notifications" to "Tile Text" creates an entry in the manifest which trips the toast "guard" for lack of a better word, requiring a WideLogo to be set. The only way to fix this is to right click on the file, View Code, and remove the <LockScreen> tag under VisualElements. I only gave the example to show that even minor changes can seemingly break your solution.

    One thing you could try is that since you have a working app, do a diff of that against your faulty package. I suspect something major is different other than GUIDs. According to twitter and here (this is for Derek) you seem to be using the same exact name and since it showed 2 entries on the start screen I suspect the registry had something to do with that. From Justin Angel's post (http://justinangel.net/ReverseEngineerWin8Apps), the registry location for this is "HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel". I suspect all of the entries starting with app. versus microsoft. are 3rd party but you have to actually go to the Repository\[AppId]\PackageRootFolder entry and practically get lucky in determining which app is yours.

    If you wanted to shortcut using regedit, you can start your search in C:\Users\[user]\AppData\Local\Expression\Visual Studio\ShadowCache\ but what it looks like is there are hundreds of folders with specific cache marks of various parts of one of my app. Some directories include the main exe, some a referenced project, and very few seem to house the entire app. You're probably safe removing everything as long as you prune the registry entries that match but you'd obviously want to be careful. You've done a refresh but since it likely doesn't touch user data this is probably left over and may need to be handled manually.

    Of course none of this may work but hopefully some combination outlined may help someone else.

    Thursday, October 6, 2011 5:07 PM
  • Ok further investigation of the registry path:

    Our apps don't start with "app." but I suspect some of the ones on the system do for whatever reason, likely because they were made outside Microsoft.

    For installed apps, you should have a PackageRootFolder entry pointing to C:\Users\[user]\AppxLayouts\[guid-based string]. You can delete anything in AppxLayouts but it doesn't uninstall the app. To uninstall you would likely need to not only remove "HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\[AppId]" but also the linked locations under "CurrentVersion\AppContainer\Storage\[AppId]", "CurrentVersion\AppContainer\Mappings\[SID mapping]" and "CurrentVersion\Packages\[AppId]".

    It looks like it's relatively trivial to build something to inspect the registry locations for you in the event something royally screws up but right click->Uninstall is the easiest way to do this obviously.

    Thursday, October 6, 2011 5:28 PM
  • Yet more investigation: You can remove everything except AppContainer\Storage\[AppId] and AppModel\Repository\[AppId] so it looks like only uninstall works for this. Even trying regedit as administrator prevents the deletion of those two keys so if manual is your only option, you may need to be in Safe Mode or some other way to edit the registry.

    I did a couple of tests and if you unpin and search for the app, it leaves the entry on the screen despite performing an uninstall. You're given a false sense of security as you can click "pin" but it doesn't do anything. I saw this with WP7 where sometimes the installer service wouldn't remove the guids when you thought it should. Some vague number of reboots would finally trip it to uninstall everything correctly.

    Sorry for the triple post but I should've inspected everything I said before blindly spouting it as a workable solution.

     

    Thursday, October 6, 2011 5:47 PM
  • Thanks very much for your hard work and persistence with this issue, Jeremy.

    I purged everything relevant I could find in the registry, deleted the relevant folder(s) from AppxLayouts, compared the manifest to a working app and made them the same in all but names, descriptions, and GUIDs and to my utter dismay the problem still existed (I checked at each stage).

    However, I went back to the multiple merged resource dictionaries aspect and decided that a single style in one of the dictionaries could be put in the main page instead, thus taking me down to a single merged dictionary. To my complete surprise, this single step resolved the issue and the app now deploys successfully and runs!

    • Proposed as answer by Derek R Lakin Friday, October 7, 2011 8:31 AM
    Friday, October 7, 2011 8:31 AM
  • Tim, the "Unable to activate Windows Tailored application" error happens whenever light_generic.xaml is added to newly created application:

    1. Create an new C# Grid Application

    2. Complie and run - works fine

    3. Drag light_generic.xaml to the project - it is added to the project and App.xaml merged dictionaries.

    4. Complie and run - app hangs at the clock start screen. Returning to VS shows the error dialog. Task manager shows a zombie process.

    Happens for Split App also.

    Friday, October 7, 2011 7:26 PM
  • @GLarson - when you drag the ligh_generic.xaml in it will add it with a leading slash (i.e., "/light_generic.xaml") which will cause this issue.  Remove the leading slash and it should work.  This is a known issue.
    Tim Heuer | Program Manager, XAML | http://timheuer.com/blog | @timheuer

    (if my post has answered your question, please consider using the 'mark as answer' feature in the forums to help others)
    • Proposed as answer by _brice Tuesday, February 7, 2012 3:21 PM
    Friday, October 7, 2011 8:28 PM
  • To contribute to the discussion, I just ran into this issue as well. I found that I had a typo in one of my styles in the app.xaml. Fixing it resolved the error. Clearly the error message is misleading/incomplete and needs to give a better indication of the underlying problem.
    http://www.ThinqLinq.com http://www.LinqInAction.net - "LINQ In Action", The book is now available. Don't wait for the movie
    Thursday, October 13, 2011 8:13 PM
  • Thanks Tim,

    Your suggestion resolved my issue, I changed

    from= <ResourceDictionary Source

    ="/Resources/Styles.xaml"/>
    To= <ResourceDictionary Source="Resources/Styles.xaml"/>

    Saturday, October 15, 2011 1:35 PM
  • I got this error, too. For me, the solution was to temporarily disconnect the extended monitor from my tablet dock.

     


    +tom Cupertino, CA
    • Edited by tom.allen Sunday, October 16, 2011 9:14 PM
    Sunday, October 16, 2011 9:13 PM
  • I currently have two PCs(laptop and desktop) intalled Win 8. This error ""Unable to activate Windows Tailored Application" only happens when complie/running C# project in desktop PC. The notebook has ndivia GeForce 8400M with resolution of 1680x1050 and desktop has ATI Radeon 5700 with resolution of 1920x1080.

    "Unable to activate Windows Tailored Application" only happens on my desktop using new application, one that I created. Newly create C++ projects and sample C# projects runs fine.

    Here is what I did

    Create new C# project, compile and run - works

    Add light_generic.xaml (Project -> Add existing item, not by dragging), compile and run - compiles buts gets this "Unable to activate Windows Tailored Application" message.

    Remove light_generic.xaml, compile and run -> still gets "Unable to activate Windows Tailored Application"

    Change appmanifest packaging name, compile and run -> still gets "Unable to activate Windows Tailored Application"

    Change resolution to smaller ones, compile and run -> still gets "Unable to activate Windows Tailored Application"

    Debug using remote debugger (remote device is tablet Iconia w500) -> still gets "Unable to activate Windows Tailored Application"

    I am trying to work with C# using my desktop - my notebook is really slow :(

    I don't know if chaning graphic card would help..

    Monday, November 28, 2011 11:06 AM
  • @Scott.hlee I had the same issue, then I found there was a reference in App.xaml where I needed to remove the starting /:

    <ResourceDictionary Source="/light_generic.xaml"/>

    Changing it to 

    <ResourceDictionary Source="light_generic.xaml"/>

    worked.

    Tuesday, January 24, 2012 9:46 PM
  • This solved the issue for me. Was testing out side loading the app. I'm guessing that caused the issue because the moment I changed one letter in the package identity name, it solved the problem. Thanks for the help!
    Thursday, April 3, 2014 2:04 PM