locked
ASP.NET is not authorized to access the requested resource. RRS feed

  • Question

  • User253482888 posted

    Hello,

     

    Ive uploaded my Webmatrix site based on the gallery template to a host that confirms they are fully WM compatable.
    When I load my page I am getting the below error and I'm not sure what to do. Suggested fix is to enable permission to the database for ASP.NET. Do I need to do this within WM or on the server? I cannot see ASP.NET listed anywhere in properties.

    Many thanks

    Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))              Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.            
    Exception Details: System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
    ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6 and IIS 7, and the configured application pool identity on IIS 7.5) that is used if the application is not impersonating.  If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.
    To grant ASP.NET access to a file, right-click the file in File Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.

    Wednesday, June 5, 2013 4:49 PM

Answers

  • User281315223 posted

    Depending on what version of IIS you are running the name may change or differ, but this is likely just a permissions issue and you'll just need to figure out the correct user or user group to apply to.

    I would recommend going through the lists of users under this Application Pool where this specific Application is running (within IIS) and try adding the appropriate permissions for IIS_USERS (or similarly named). 

    (You can find instructions on how to handle this in this Stack Overflow discussion).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, June 5, 2013 5:08 PM
  • User-821857111 posted

    If the code that's throwing the error is running on your server, that's where you need to set the permissions. You should check with your hosting company on how to do that.

    The usual solution is to allow the appropriate user account to have MODIFY permissions on App_Data. This is needed if you are using the default SQL CE database.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 6, 2013 2:24 AM
  • User253482888 posted

    I was hesitant to name and shame until I received the latest response from them:

    The company is ASP Host Portal (as recomened by Microsoft).

     

    LB(client) said:

    Is the $15.00 Webmatrix activation fee covered by the 30 money back cancellation policy?

    Joel Y. (staff) said:

    Hi LB,

    All setup fees and addon fees are always non-refundable.
    Thank you.

     

    Kind Regards,

    Support Team

    LB(client) said:

    Dear Joel,

    Your last statement conflicts with the sales pitch on your main website that says in the FAQ section:

    Can I get a demo account ?

    We dont provide demo accounts but we have a 30-day money back guarantee. So you can just sign up for a normal account and if youre not happy with the service just cancel within 30 days and well give you a full refund.

    http://www.asphostportal.com/Windows-Shared-Hosting-Plans.aspx

    Please can you clarify.

    Thank you

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, June 11, 2013 2:56 PM

All replies

  • User281315223 posted

    Depending on what version of IIS you are running the name may change or differ, but this is likely just a permissions issue and you'll just need to figure out the correct user or user group to apply to.

    I would recommend going through the lists of users under this Application Pool where this specific Application is running (within IIS) and try adding the appropriate permissions for IIS_USERS (or similarly named). 

    (You can find instructions on how to handle this in this Stack Overflow discussion).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, June 5, 2013 5:08 PM
  • User253482888 posted

    Hi Rion,

    Thanks for your very quick reply :)
    Do I do this within Webmatrix of on my host server?
    On the host server Plesk ISS User is all set to "Allow".

    Am I looking at the wrong thing?

    Thanks again

    Full Control <input name="AllowFull" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyFull" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    Read Control <input name="AllowRead" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyRead" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    Write Control <input name="AllowWrite" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyWrite" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    Execute Control <input name="AllowExecute" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyExecute" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    Traverse Folder / Execute File <input name="AllowTraverseFolderOrExecuteFile" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyTraverseFolderOrExecuteFile" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    List Folder / Read Data <input name="AllowListFolderOrRead" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyListFolderOrRead" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    Create Files / Write Data <input name="AllowCreateFilesOrWrite" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyCreateFilesOrWrite" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    Create Folders / Append Data <input name="AllowCreateFoldersOrAppend" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyCreateFoldersOrAppend" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    Delete <input name="AllowDelete" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyDelete" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    Change Permissions <input name="AllowChangePermissions" class="checkbox" type="checkbox" checked="checked" value="true" autocomplete="off" /> <input name="DenyChangePermissions" class="checkbox" type="checkbox" value="true" autocomplete="off" />
    Take Ownership
    Wednesday, June 5, 2013 5:18 PM
  • User253482888 posted

    Sorry for the long pated reply - It looked different before I submitted :S

    Wednesday, June 5, 2013 5:19 PM
  • User-821857111 posted

    If the code that's throwing the error is running on your server, that's where you need to set the permissions. You should check with your hosting company on how to do that.

    The usual solution is to allow the appropriate user account to have MODIFY permissions on App_Data. This is needed if you are using the default SQL CE database.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 6, 2013 2:24 AM
  • User-1186424966 posted

    Hello,

    I use Host4Life hosting and there is option named "Additional write/modify permissions". I don't now what and where it sets, but it 100% resolves this problem.

    Vladimir

    Friday, June 7, 2013 12:49 AM
  • User253482888 posted

    Thanks for your suggestions. I have the settings set to allow modification etc but still no joy.

    The host is now saying that to use Webmatrix there is a one off activation fee that they previously failed to mention.

    They arent as helpful as they could be and they are the host recomended by MS Webmatrix so its no like they are just anyone.

    I will pay the fee and hope that helps.

    Monday, June 10, 2013 3:12 PM
  • User-821857111 posted

    The host is now saying that to use Webmatrix there is a one off activation fee that they previously failed to mention.
    Name and shame them, please. 

    Monday, June 10, 2013 4:37 PM
  • User253482888 posted

    I was hesitant to name and shame until I received the latest response from them:

    The company is ASP Host Portal (as recomened by Microsoft).

     

    LB(client) said:

    Is the $15.00 Webmatrix activation fee covered by the 30 money back cancellation policy?

    Joel Y. (staff) said:

    Hi LB,

    All setup fees and addon fees are always non-refundable.
    Thank you.

     

    Kind Regards,

    Support Team

    LB(client) said:

    Dear Joel,

    Your last statement conflicts with the sales pitch on your main website that says in the FAQ section:

    Can I get a demo account ?

    We dont provide demo accounts but we have a 30-day money back guarantee. So you can just sign up for a normal account and if youre not happy with the service just cancel within 30 days and well give you a full refund.

    http://www.asphostportal.com/Windows-Shared-Hosting-Plans.aspx

    Please can you clarify.

    Thank you

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, June 11, 2013 2:56 PM