locked
Error with .NET Framework

    Question

  • Error    1    Could not find SDK "Microsoft.WinJS.1.0, Version=1.0".    C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets    1682    6    Geolocation
    Sunday, September 16, 2012 8:18 PM

Answers

  • VS2012 RC doesn't use version 1.0 of Microsoft.WinJS.  You need the RTM version of Visual Studio 2012.
    • Proposed as answer by Dino He Thursday, September 27, 2012 2:20 AM
    • Marked as answer by Dino He Friday, September 28, 2012 2:22 AM
    Thursday, September 20, 2012 3:55 PM
  • HI

    I think you just download some SDK samples and find it can't deployed successful.

    This sample use Microsoft.WinJS.1.0 , as skills0 said doesn't use version 1.0, VS RC is for windows RP, now some API changes in windows RTM, you should install VS 2012 RTM if you installed windows RTM.

    • Proposed as answer by Dino He Thursday, September 27, 2012 2:20 AM
    • Marked as answer by Dino He Thursday, October 11, 2012 8:01 AM
    Thursday, September 27, 2012 2:20 AM

All replies

  • Can you explain more about the context in which you see this error?

    --Rob

    Sunday, September 16, 2012 11:41 PM
    Owner
  • I am also getting the Same Error

    Error 1 Could not find SDK "Microsoft.WinJS.1.0, Version=1.0". C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets

    when i try to run javascript sample for Background Transfer : Download and upload Sample Metro App.

    I have Windows 8 RTM and VS2012 RC

    Wednesday, September 19, 2012 7:49 AM
  • Rob, Can you please Help ASAP.
    Wednesday, September 19, 2012 7:50 AM
  • VS2012 RC doesn't use version 1.0 of Microsoft.WinJS.  You need the RTM version of Visual Studio 2012.
    • Proposed as answer by Dino He Thursday, September 27, 2012 2:20 AM
    • Marked as answer by Dino He Friday, September 28, 2012 2:22 AM
    Thursday, September 20, 2012 3:55 PM
  • HI

    I think you just download some SDK samples and find it can't deployed successful.

    This sample use Microsoft.WinJS.1.0 , as skills0 said doesn't use version 1.0, VS RC is for windows RP, now some API changes in windows RTM, you should install VS 2012 RTM if you installed windows RTM.

    • Proposed as answer by Dino He Thursday, September 27, 2012 2:20 AM
    • Marked as answer by Dino He Thursday, October 11, 2012 8:01 AM
    Thursday, September 27, 2012 2:20 AM