none
color and depth image didn' t showed(C#) RRS feed

  • Question

  • I wrote a program just show the color and depth image from Kinect used C#, it worked. Someday I found it could execute but the color and depth image didn’ t show. And the depth viewer and color viewer in Kinect studio were empty too. I fixed it by reinstall visual studio and Kinect SDK many times, but now it happened again. How could I fix the problem? I don’t want to reinstall again and again.  And could it be my fault that I remove Kinect directly? But in the other computer (PC) this problem never happened, only on my Notebook.

    Friday, March 8, 2013 1:05 PM

All replies

  • Are you sure you are getting enough power to the kinect? At my work I do some testing but the computer is an older one and the kinect quality is not as good because of the power it is receiving.  I use the kinect sdk chooser control in wpf so it tells me if I need power (sometimes if you do not get enough power the control will not say the kinect is plugged in and then then resume with the color and depth image stream after plugging it back in. I have only had this happen on an older dell optiplex at my work before but not on my laptop).


    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt. Fear leads to anger, anger leads to hate, hate leads to suffering - Yoda. Blog - http://www.computerprofessions.co.nr



    Sunday, March 10, 2013 8:24 PM
  • Well, I tested Kinect on my desktop and laptop in the same place, so I guess the power is enough. And for check power by program, I couldn't figure out how to do that. Would you like to post your code?

    By the way, my laptop is also dell, so....hopefully it just a coincidence.
    Tuesday, March 12, 2013 5:03 PM