locked
My app is not available to lumia 620 RRS feed

  • Question

  • Hello,

    My app supports both wp8 and wp7, and I have two binaries published to the store. In Lumia 920 I can download the wp8 version of my app but when I try to download using lumia 620, the app downloaded is the wp7 version and not the wp8 version.

    Am I missing something?

    thanks in advance


    • Edited by LBSLocal Thursday, April 4, 2013 6:37 PM
    Thursday, April 4, 2013 6:31 PM

Answers

  • Hello Tiago,

    I talked to the agent that is working on your case and he should be contacting you shortly about your issue.

    It looks like your WP7 and WP8 XAPs have the same version number so this is why you are running into this issue. You will need change the WP8 version to a higher version number and then resubmit both XAPs. If both XAPs have the same version number the Store will always deliver the WP7 version.

    -Eric

    Windows Phone Developer Support

    • Marked as answer by LBSLocal Saturday, April 13, 2013 11:11 AM
    Friday, April 12, 2013 5:46 PM

All replies

  • Hello LBSLocal,

    Usually we see this happen when the WP7 version lists support for WP8 or when both the WP7 and WP8 versions have the same version number. The Store will deliver the WP7 version as the "safe" version whenever there is a conflict.

    The WP8 version of your app should always be a higher version number to avoid this issue.

    If you need us to look at your app please contact developer support and we determine the exact cause of your issue.

    -Eric

    Windows Phone Developer Support

    Friday, April 5, 2013 5:12 PM
  • Hi Eric,

    I've contacted the developer support and they said that they will investigate this issue.

    Thanks for your help,

    Tiago


    • Edited by LBSLocal Friday, April 5, 2013 10:39 PM
    Friday, April 5, 2013 10:15 PM
  • Hello Tiago,

    If you would like for me to check on your case please post the SR # so I can check with the agent that is working your case.

    -Eric

    Windows Phone Developer Support

    Tuesday, April 9, 2013 5:48 PM
  • Hi Eric,

    I appreciate your help. The SR # is SRX1202027600ID.

    Tiago

    Thursday, April 11, 2013 7:27 PM
  • Hello Tiago,

    I talked to the agent that is working on your case and he should be contacting you shortly about your issue.

    It looks like your WP7 and WP8 XAPs have the same version number so this is why you are running into this issue. You will need change the WP8 version to a higher version number and then resubmit both XAPs. If both XAPs have the same version number the Store will always deliver the WP7 version.

    -Eric

    Windows Phone Developer Support

    • Marked as answer by LBSLocal Saturday, April 13, 2013 11:11 AM
    Friday, April 12, 2013 5:46 PM
  • I've just uploaded my XAPs as a beta app and it worked. Thank you Eric. 
    Saturday, April 13, 2013 11:11 AM
  • Hello Tiago,

    That's fantastic! Thank you for confirming that your issue was resolved.

    -Eric

    Windows Phone Developer Support

    Tuesday, April 16, 2013 5:13 PM
  • Hi Eric,

    I have a similar problem, that after my update published for both WP7(3.2) and WP8(4.2) versions the windows phone 8 users now get the wrong wp7(3.2) version of my app.

    You said that: "Usually we see this happen when the WP7 version lists support for WP8".
    Can you please explain it what does list support for wp8 mean? Where we specify it?

    Maybe I accidentally "list support for WP8", but in which file or where can I delete/remove this support for WP8??

    In the capabilities there is no CAP_... for wp8, so where can I found it?

    Thanks,

    Tom

    Thursday, April 18, 2013 1:16 AM
  • Hi Eric,

    I have a similar problem, that after my update published for both WP7(3.2) and WP8(4.2) versions the windows phone 8 users now get the wrong wp7(3.2) version of my app.

    You said that: "Usually we see this happen when the WP7 version lists support for WP8".
    Can you please explain it what does list support for wp8 mean? Where we specify it?

    Maybe I accidentally "list support for WP8", but in which file or where can I delete/remove this support for WP8??

    In the capabilities there is no CAP_... for wp8, so where can I found it?

    Thanks,

    Tom

    Thursday, April 18, 2013 1:17 AM
  • Hello Tom,

    That is defined by the "Target Windows Phone Platform" when you create your project.

    This article explains how to support both WP7 & WP8 with separate XAP files. 

    Also see How to target Multiple Versions with your App

    -Eric

    Windows Phone Developer Support

    Thursday, April 18, 2013 5:28 PM