locked
can't open sharepoint site with sharepoint designer 2010 RRS feed

  • Question

  • Hi there,

    We've installed SP Foundation + SP Server 2010 and set up some sites.

    when we tried to open it with SP Designer 2010, it fails and gave us some errors.

    opening SPD through site actions :
    unable to open website. possible causes:
    1. the web server may not have sharepoint server installed
    2. the web server may be temporarily out of service
    3. if you are connecting through a proxy server, the proxy settings may be incorrect
    4. an error may have occured in the web server

    opening sharepoint site through SPD:
    the folder 'http://mysp.domain.com/site/default.aspx' isn't accessible. the folder may be located in an unavailable location, protected with a password, or the filename contains a / or \.

    the thing is ... we have no problem with sharepoint designer 2007.

    any idea?

    Monday, August 9, 2010 7:17 AM

Answers

  • Sam, there is an issue with web applications that have more than one binding in IIS.  When there is more than one, the site can't be opened.  To get around this, I have extended my web application to a new URL (host header) and used that URL to connect with SPD2010.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, August 18, 2010 4:50 AM

All replies

  • Hello,

    Go to your Central Administration website > General Application Settings > SharePoint Designer.  Select the web application that is hosting your site collection and verify that SharePoint Designer is enabled.

    FYI, SharePoint Designer 2007 is not designed to be used with SharePoint 2010 and vice versa (it is also not Microsoft supported).  Only use the corresponding version of SharePoint with SharePoint Designer. 


    Chris Caravajal MCTS SharePoint Help
    Monday, August 9, 2010 9:59 AM
  • if you want to open a site in SPD , it should be 'http://mysp.domain.com/site you cant include you`r default.aspx

     

    and you have to be site admin

     

     


    Share Knowledge and Spread Love!
    • Proposed as answer by AndyGett Monday, August 9, 2010 7:55 PM
    • Unproposed as answer by p.andrew Tuesday, August 10, 2010 2:32 AM
    • Proposed as answer by SPKID Wednesday, February 27, 2013 4:24 PM
    Monday, August 9, 2010 2:12 PM
  • thanks for the reply.

     

    @chris:

    I did checked the SPD settings in central admin and they're all enabled

     

    @SPKID:

    This is done on the sharepoint server itself:
    In SPD, i clicked open site and put in http://mysp.domain.com/path/mysite but it just display a list of folders and I'm not sure which one to open.

    When I tried to do the same thing from a client pc, I got the same error message:
    the folder 'http://mysp.domain.com/path/mysite' isn't accessible. the folder may be located in an unavailable location, protected with a password, or the filename contains a / or \.

    this doesn't make sense!

    Tuesday, August 10, 2010 2:31 AM
  • Hi p.andrew,

     

    If you want to open the site use SPD, you should enable the Client Integration for the web application at first.

    Here are the steps:

    1.       Go to this location : “Central administration” > “Security” > “Specify authentication provider”;

    2.       Select the Web Application which you want to edit use SPD (SharePoint Designer 2010), and click the “Default” below the ‘Zone’;

    3.       Select the “Yes” radio button  in the Client Integration section, and click the ‘Save’ Button;

    4.       Close and re-Open the IE;

    5.       Try to Open the site using SPD.

     

    More information about this:

    http://snahta.blogspot.com/2009/01/folder-may-be-located-in-unavailable.html

    http://skurocks.wordpress.com/2009/06/26/enable-client-integration-user-permissions-for-web-application-%E2%80%93-caution/

    Tuesday, August 10, 2010 8:11 AM
  • value for enable client integration is already yes .

    so basically all the settings you mentioned are already set as it is.
    (SPD should work from the very start and the fact the SPD 2007 "works", it doesn't make sense why 2010 not)

    Tuesday, August 10, 2010 9:27 AM
  • Hey Andrew... I am exactly in a similar situation and have same symptoms. Did you find the cause or the solution to this problem?

    Thanks,
    - Sam

    Tuesday, August 17, 2010 9:39 PM
  • >>the thing is ... we have no problem with sharepoint designer 2007.

    You cannot open SharePoint 2010 sites in SharePoint Designer 2007. I am not sure how you are actually opening it unless http://mysp.domain.com is running SharePoint 2007.

    Things to check:

    1) Is mysp.domain.com host headed? If so, have you added the entry to c:\windows\system32\drivers\hosts file?

    2) Do you have any proxy in your network?

    3) Check Windows Event Viewer for any logs


    Regards,
    Chakkaradeep || SharePoint Solutions Specialist - MCTS SharePoint Dev, WSS Dev, MCPD SharePoint Developer 2010
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Tuesday, August 17, 2010 9:56 PM
  • Chandran,

    My environment is Win 2008 R2, SP 2010 RTM, SQL Server 2008 R2 

    there is another thread on this exact topic but that didnt reolve my problem (http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010general/thread/972888f0-66a5-4010-bd6e-b869ea5ba193).  Apparently there was a build problem.

    SharePoint 2010 Build :  14.0.4763.1000
    SP Designer 2010 Build:  14.0.4763.1000   (same)

    1) It have tried to open a site which was host headed with the same results. The entry was made in the host file.

    2) No Proxy

    3) Nothing is in the error log

    Now its giving me this error when I try to open a site.

    An error occured while trying to fetch data from your SharePoint site. Unexpected response from the server. The content type of the response is "". The status code is "OK"

     

     

     


     

    Tuesday, August 17, 2010 10:12 PM
  • As Chaks said, you can only use SPD2010 with SP2010 and SPD2007 with SP2007.  This would be the reason you can't get it to work.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, August 18, 2010 4:49 AM
  • Sam, there is an issue with web applications that have more than one binding in IIS.  When there is more than one, the site can't be opened.  To get around this, I have extended my web application to a new URL (host header) and used that URL to connect with SPD2010.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, August 18, 2010 4:50 AM
  • Thanks Clayton. It worked!

    I extended the web application and assigned it a new URL(host header). Once i did that i was able to open the site in SharePoint designer.

    Wednesday, August 18, 2010 4:01 PM
  • Glad that helped, Sam.  Can you verify which versions of SP2010 and SPD2010 you're using?  Are you using RTM?
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, August 18, 2010 5:54 PM
  • Yes they are RTM's.

    SharePoint 2010 :  14.0.4762.1000

    SharePoint Designer 2010: 14.0.4763.1000

     

     

    Wednesday, August 18, 2010 7:59 PM
  • Hi Clayton,

    Can you please help me out with the same issue? Here's my situation:

    I am using SP2010(14.0.4762.1000) + SPD2010 - 32Bit (14.0.4760-1000) in a Window 7 Home Premium (64 Bit) Environment. I have a stand alone configuration with SQLExpress. I am currently using the computer name to connect to my site and central administration so there is not need to configure AAM. I have 1 binding on each site. SPD2010 is enable for the application and on the default site. But I am getting the same error message.

     

    Any ideas?

     

    Thanks.

    Tuesday, August 24, 2010 4:48 PM
  • hi all,

    I was on holiday so I can't test this out til I got back next week.

    in the mean time, I've never do this "application extension" before so I'm not sure what you mean by it.

    can someone guide me through it?

     

    PS:
    The server was doubled as our standard web server so the sites accessible are:
    www.domain.com
    sharepoint.domain.com

     

    Tuesday, August 24, 2010 5:07 PM
  • p.andrew, what are you referring to by "application extension"?  I must have missed it.

    Also, your sharePoint server should _not_ be doubling as a standard web server.  It is not just a standard web application - it's an enterprise collaboration framework.  It should not be sharing resources in that manner.  JMO...


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, August 25, 2010 2:01 AM
  • akhanaton, things are much more difficult when trying to put a server product on a desktop OS.  I haven't done that - I always use Windows Server, so I haven't had to troubleshoot it with Windows 7.  My only question would be...why are your versions mismatched?  Are you certain you have RTM builds of both?
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, August 25, 2010 2:02 AM
  • @clayton: it's on the post that has been marked as the answer.

    sorry, it should be extending web application

    about doubling as a standard web server ... yes I do know that it's not the best thing to do but I just "following" what has been configured previously by another IT person (he left the company)

     

    another thing, the site (sharepoint - 80) has only 1 binding so I assume I don't need to extend my web application, right?

    • Edited by p.andrew Monday, August 30, 2010 8:37 AM binding info
    Thursday, August 26, 2010 5:46 AM
  • Sorry about the delay in my response. In the end, I just decided to save myself the headache and installed it on server 2008. Had no problems.

    Thanks for the help though.

    Sunday, September 19, 2010 12:12 AM
  • We ran into the same problems and it took awhile to find a solution.  In our case the resolution was to have the SPD user add the site to their trusted sites in IE.

    • Proposed as answer by Brad Pfeffer Wednesday, March 9, 2011 3:43 AM
    Friday, November 5, 2010 11:01 PM
  • again, sorry for the late response.

    we tried adding the address to the trusted list and it's still not working.

    in the end we just create a new server with a sp2010 fresh install on it and no more trouble.


    Andrew P.
    Tuesday, November 9, 2010 11:27 PM
  • Hi Clayton,

     Thanks for the post...Just the perfect solution for my SPD problem. After removing the extra binding from IIS it worked like magic...Can you please give me any idea as to why it failed when an extra binding was in place?

    Regards,

    Kivuos

     


    Thursday, August 4, 2011 3:25 AM
  • Hi,

     

    We had a similar problem. In our environment we were using Kerberos through Claims Based Authentication. The problem was the "All Authenticated Users" group in the visitors group of the site. As soon as you remove that user group SPD works fine.

    Wednesday, December 21, 2011 10:17 AM
  • I got the same issue in SharePoint 2010 and SharePoint designer 2010 and I found the event log "reduce the load on the machine or adjust the value of minFreeMemoryPercentageToActivateService on the serviceHostingEnvironment config element."

    Following the tip,I restart IIS and restart the SharePoint designer again,the site can be opened.


    Devote Innovate Share || Mingle.Lui@live.com
    Blog
    Wednesday, January 4, 2012 9:44 AM
  • This is the one that helped my instance of this error .. as previously pointed out above, all settings checked out fine and in fact, the bindings were changed a few days ago by me and that was only the addition of one binding to the existing two that were already present, but yesterday, I setup a new web app and site collection for CRM integration and as a result of this, am thinking that restarting IIS several times cause the bindings to take effect across the board even though they should've already...I say this cause I can't see any other reason why suddenly today, I was unable to connect via SPD2010 .. I saw your post and removed 2 of the 3 bindings and voila, it connected just fine .. added the two back, restarted the site in IIS and problem occurred again .. removed JUST the empty host header record, restarted the site in IIS and am connecting again.  Possibly, just something with the empty host header?  I now have two host headers instead of the 3 (removed the empty one) and can now connect again.  Thank you for leading me in the correct direction to resolve this.
    Wednesday, February 13, 2013 7:59 PM
  • Setting the Trusted Site worked for me. 

    I was able to open my dev site from an older PC, but my new PC would not, so I knew it wasn't site related. It had to be local to the PC, and this did the trick.


    A true software developer is one who, when told to 'Go to Hell', sees the 'go to', rather than the destination, as harmful.

    Tuesday, May 14, 2013 1:20 PM
  • I tried all the other solutions, no more than one binding, trusted sites, etc. Werner's answer got me to thinking about the authentication angle. Turns out Anonymous Authentication was enabled on the site in IIS (DEV machine). Disabling Anon Auth via INETMGR allowed me to connect with SPD.
    Wednesday, June 5, 2013 3:24 PM
  • Hi Clayton,

    I have done above but unable to browse site and getting below error..

    "The control type 'CTC_Webparts.ctc_leftTree.ctc_leftTree' is not allowed on this page. The type is not registered as safe."

    Please share your experience to over come this.

    Thanks

    Chandra

    Friday, July 12, 2013 11:23 AM
  • I had the same issue  after changing the web bindings on my Web Front End (WFE) servers and I didn't want to extend my Web Application. So, this is what I did:

    [Central Admin>Security>General Security | specify authentication providers] 

    >Default Zone 

    Set [Enable Client Integration?] = (No)

    [Save]

    ...

    Then repeated the process but 

    Set [Enable Client Integration?] = (Yes)

    [Save]

    I then ran "iisreset" from the command prompt on each of my WFE servers

    and that did the trick for me.

    I hope this helps.

    Wednesday, June 11, 2014 5:55 PM