locked
V5 API problems with large campaigns RRS feed

  • Question

  • Hi,

    I am  porting our V4 implementation to V5 and now that we are testing V5 in production I get frequent errors that seem to be related to the size of the data returned.

    Places where it fails: GetAdsByAdGroupIdRequest (most often) and GetAdGroupsByCampaignIdRequest (sometimes). In some cases after trying several times it works but in other places it never works.

    I increased all timeouts in the config file to 2 minutes and implemented the recommendations from this article:
    http://www.adcentercommunity.com/blogs/api/archive/2008/04/29/handling-large-arrays-in-api-v5-net.aspx
    This made some calls to work but it is still failing for a lot of calls.

    I am wondering if this is a common or known problem with V5. If so I can just wait until it is fixed, V4 still works well for us.

    Thanks,
    Tibor

    Wednesday, May 7, 2008 6:03 PM

All replies

  • Tibor,

     

    On which infrastructure are you seeing this behavior (Production or Sandbox)?  Also, on which date and time did you observe this?

     

    If this continues to be an issue, I would encourage you to escalate the issue to the Support team through your normal support channel.

     

    Thank you.

     

    Steven Hong, MSFT

    Thursday, May 8, 2008 12:47 AM
  • Hi Steve,

    I was just testing it again and it is now working fine so I guess it was a temporary glitch. I was suspecting something like this so I thought I'd ask in the forum before I start ringing the big bell.

    For the record:

    I was having the problems in the Production environment.

    The date and time was just before my original post. I tested for at least an hour or so at the time.

    Regards,
    Tibor

    Thursday, May 8, 2008 1:31 AM