locked
Excel Trusted Location Login RRS feed

  • Question

  • We added some excel spreadsheets to our SharePoint Foundation 2010 site and found out we needed a Excel Trusted location. So I read on how to set one up and now that I have it setup it asks us to login, but it never continues. It tells us an error has occurred. I have set "File Access Method" to "Process Account".

    The error is - "An error has occurred trying to perform the requested action, please try again"

    That after trying to login 3 times.

    I also have it set to open in browser.

    Wednesday, August 31, 2011 2:19 PM

Answers

  • The SSS is not supported in Foundation and is what provides single-sign on functionality for Excel Services.
    http://sharepoint.nauplius.net
    • Marked as answer by sahajin Monday, September 19, 2011 4:27 PM
    Monday, September 19, 2011 4:27 PM

All replies

  • Hi,

    I don't think sharepoint foundation 2010 will provide excel services features, how did you setup excel trusted location?

    http://sharepoint.microsoft.com/en-us/buy/pages/editions-comparison.aspx

    For sharepoint server 2010, please refer to:

    http://technet.microsoft.com/ru-ru/library/ff191194.aspx

    http://technet.microsoft.com/en-us/library/ee662541.aspx

    Regards,

    Seven

    Friday, September 2, 2011 7:57 AM
  • Easy, I did what this said

    http://technet.microsoft.com/ru-ru/library/ff191194.aspx

    To add a trusted file location

    1. Verify that you have the following administrative credentials:

      • To create a service application, you must be a member of the farm administrators group.

    2. On the Central Administration home page, click Application Management.

    3. On the Application Management page, in the Service Applications section, click Manage service applications.

    4. On the Manage service applications page, click Excel Services Application. This is the default service that you will configure.

    5. On the Manage Excel Services Application page, click Trusted File Locations.

    6. On the Excel Services Application Trusted File Locations page, click Add Trusted File Location.

     

    It tries to open the excel in the InBrowser option but also asks for a login but never lets you login, come back with the above error.

    Friday, September 2, 2011 3:23 PM
  • Anybody else, would love to find a solution to this problem.
    Monday, September 19, 2011 2:30 PM
  • In order to add Excel sheets to a SharePoint site, you don't have to do anything special.  Foundation doesn't include Excel Services.
    http://sharepoint.nauplius.net
    Monday, September 19, 2011 3:33 PM
  • But I do have excel services. I see it running. When we clicked on an excel file it first said an error because there was no trusted location. As soon as I added the trusted location is when it prompts for login but never lets you login.
    Monday, September 19, 2011 4:17 PM
  • Do you have the Secure Store Service set up and Excel hooked into the Secure Store Service?
    http://sharepoint.nauplius.net
    Monday, September 19, 2011 4:20 PM
  • ahh, thats the service I cannot find or add. So thats the part that is not supported in Foundation? And I take that back, I have excel calculation service, not excel service like I have for word.
    Monday, September 19, 2011 4:24 PM
  • The SSS is not supported in Foundation and is what provides single-sign on functionality for Excel Services.
    http://sharepoint.nauplius.net
    • Marked as answer by sahajin Monday, September 19, 2011 4:27 PM
    Monday, September 19, 2011 4:27 PM
  • Thank you Trevor. solves everything
    Monday, September 19, 2011 4:27 PM
  • I got it fixed simply by restarting Microsoft SharePoint Foundation Web Application service In Central Administration > Application Management >  Manage Services on Server.
     

    Taras1234567

    Monday, October 14, 2013 5:20 PM