none
My Visual Studio 2015 community's color theme editor is getting disabled !!

    Question

  • I installed color theme editor for visual studio 2015 community edition , but it is always requiring a restart to work. i have to enable and restart visual studio every time I start it. and although it works on the restart, it again gets disabled on next startup. i tried to understand the problem but was unable to do so ! Can anyone tell me whats the problem? 

    Thanks!

    Monday, January 16, 2017 7:03 AM

Answers

  • Hi,

    The problem of VS extensions becoming disabled seems to be related to the extension installed twice in two random folders of the folder:

    C:\Users\<user>\AppData\Local\Microsoft\VisualStudio\14.0\Extensions

    Can you verify?

    To solve it proceed as follows:

    - Uninstall the extension in the Extension Manager

    - Close VS

    - Go to that folder

    - Ensure that no folder (those with random names) contains the files of the extension. If so, delete the folder.

    - Reinstall the extension


    My portal and blog about VSX: http://www.visualstudioextensibility.com
    Twitter: https://twitter.com/VSExtensibility
    MZ-Tools productivity extension for Visual Studio: https://www.mztools.com

    Monday, January 16, 2017 11:14 AM

All replies

  • Hi miteshryp,

    Welcome to MSDN forum.

    Did you install it via this website below?

    https://marketplace.visualstudio.com/items?itemName=VisualStudioProductTeam.VisualStudio2015ColorThemeEditor

    I just tried to install it and it works fine in my side. And my environment is VS 2015 Community Update 3.

    There are several tips might be helpful to you:

    Please update your Visual Studio 2015 to the latest update if it’s not.

    It might be caused by the level of permissions, you could

    Run the VS with administrator to install the theme color editor again.

    Also, please try to export the environment settings after you just installed the color theme editor, export it to a public folder which all user could access, and import the settings again when your run the VS.

    You could find the export/import settings: tools -> import and export settings

    In addition, I could see the color theme editor window here, tools -> extensions and updates

    The button could be set disable or enable and when it shows disable the color theme editor works, I mean I can switch it and it works here,  hope it’s helpful.

    You could check if this is caused by permissions’ issue, you may refer to this blog:

     https://blogs.msdn.microsoft.com/astebner/2006/09/04/solving-setup-errors-by-using-the-subinacl-tool-to-repair-file-and-registry-permissions/

    Please try the methods above and let us know the result. Good luck.

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, January 16, 2017 10:41 AM
  • Hi,

    The problem of VS extensions becoming disabled seems to be related to the extension installed twice in two random folders of the folder:

    C:\Users\<user>\AppData\Local\Microsoft\VisualStudio\14.0\Extensions

    Can you verify?

    To solve it proceed as follows:

    - Uninstall the extension in the Extension Manager

    - Close VS

    - Go to that folder

    - Ensure that no folder (those with random names) contains the files of the extension. If so, delete the folder.

    - Reinstall the extension


    My portal and blog about VSX: http://www.visualstudioextensibility.com
    Twitter: https://twitter.com/VSExtensibility
    MZ-Tools productivity extension for Visual Studio: https://www.mztools.com

    Monday, January 16, 2017 11:14 AM
  • Yes! that was the problem! thank you very much Carlos J. Quintero , i have been after this thing since yesterday but was unable to solve the problem. thank you very much!!!!

    Monday, January 16, 2017 5:28 PM