none
the "creat list workflow " window does not appear

    Question

  • Hi,every body.

    I have a strange problem with sharepoint designer 2013.

    You know when you want to create workflow for one list in sharepoint designer you click on workflows in site objects then you open the list workflow and select your list after that the " create list workflow " window such the below picture appears:

    create list workflow

    My problem is: in one of sitecollection and its subsites this window does not open!!!!!!!!!!!!!!!!!!!!!without any errors and messages. just that does not open!!!! (in the other sitecollection in same webapplication the window  appears and it works normally)

    why? Is there any suggestion?

    Saturday, February 18, 2017 6:26 AM

All replies

  • Hi AvahitHeidarnezhad,

    For this issue, please check if you could create a workflow with SharePoint build-in workflow templates.

    Open a list/library in the site collection which is having the issue, click on “Workflow Settings” under “List/Library” tab on the ribbon. Check whether you could add a workflow.

    In addition, clear SharePoint Designer cache and compare the result.

    1. Close SharePoint Designer 2013;

    2. Delete all the files from location: %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache;

    3. Delete all the files from location: %APPDATA%\Microsoft\Web Server Extensions\Cache.

    Information about how to Clear Your SharePoint Designer 2010/2013 Cache:

    http://www.c-sharpcorner.com/UploadFile/sagarp/how-to-clear-your-sharepoint-designer-20102013-cache/

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, February 20, 2017 5:02 AM
    Moderator
  • Hi ,Linda  Zhang

    thanks for your suggestions

    the result of "check if you could create a workflow with SharePoint build-in workflow templates" is positive.

    I traced a link you mention I do the instruction of that except %APPDATA%\Microsoft\Web Server Extensions\Cache becuse i can't find it . but i do the other steps .

    i open sharepoint designer again but the problem persists...do you have any other suggestion?

    oh one another things when i open sharepoint designer and click on workflows in the first time our workflows didn't appear(flash one and then disappear) but when click another objects (for example lists and libraries)and then back to workflows they appeared!!!!!!! I know this is very strange:

    after that

    Monday, February 20, 2017 10:04 AM
  • Hi AvahitHeidarnezhad,

    Please try installing the latest update -- August 2, 2016, update for SharePoint Designer 2013 (KB3114721) -- for SharePoint Designer 2013 to check whether the issue is still there.

    Note: To apply this update, you must have Microsoft SharePoint Designer 2013 Service Pack 1 installed.

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, February 21, 2017 2:14 AM
    Moderator
  • Hi, Linda Zhang

    I installed that update in my computer and checked it from view updates restart my computer after that I try to create workflow but the problem still persists. I clear sharepoint designer cache again but status does not change.

    one interesting  thing is i can create workflow from this part :

    Tuesday, February 21, 2017 6:03 AM
  • Hi AvahitHeidarnezhad,

    How many workflows runs in this site collection?

    Please try capturing a Fiddler trace when creating workflows in SharePoint Designer to see what is failing.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, February 27, 2017 1:53 AM
    Moderator
  • Hi ,Linda  Zhang

    thanks for reply. Do you explain about Fiddler trace more? do you have a link for that?(there isn't any failing or error the window for that does not apear!!!)this site collection have 25 workflows in root . do you mean all of workflows in root and subsites?

    I'm waiting for reply thanks.

    Monday, February 27, 2017 9:59 AM
  • Hi AvahitHeidarnezhad,

    Here is an article about Fiddler. We can use Fiddler to log all HTTP(s) traffic and check if there is something wrong when creating the workflow.

    http://www.telerik.com/fiddler

    In addition, please try using SharePoint Designer in other computer to see if it only occurs on the SharePoint Designer client application in your computer.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, February 28, 2017 1:54 AM
    Moderator
  • Hi ,Linda  Zhang

    thank you for your reply

    I check it on another clients. In every place this sitecollection have this problem.

    I install fiddler and run it . it seems to show traffic between my client and sites that I open.

    I do this tasks in below order:

    open our sitecollection(that we discuss about that) in sharepoint designer during that I monitor it in fiddler:

    I click on the workflows link itc doee not work (and i don't see any recored on fiddler) I click on lists and libraries then back workflows i see them. after that i started to create workflow but didn't apeared any window to create that and any record in fiddler....

    second try with correct sitecollection I repeated all of tasks in that and the result is like the below picture

    the record "..../client.svc/processQuery" in this sitecollection the main difference between them.

    I think when click on one list in "list workflow" button in the  ribbon(related to workflow tab in sharepoint designer) in the failed site collection there isn't any network traffic and there isn't any communications between them. this button doesn't work only in this sitecollection!!!!!!!

    I confused alot about this.

    Tuesday, February 28, 2017 10:14 AM
  • Hi AvahitHeidarnezhad,

    For this issue, you could create list workflow from File -> Add item temporarily.

    Anyway, I will keep an eye on this issue. It would also be appreciated if you can keep updating this thread once there any finding or idea about it.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, March 01, 2017 9:16 AM
    Moderator