locked
Local kernel debugging RRS feed

  • Question

  • Hi all

    When I tried to start kernel debuger I got the following error.

    "Local kernel debugging requires Windows XP, Administrative
    privileges, and is not supported by WOW64.
    Only a single local kernel debugging session can run at a time.
    Local kernel debugging is disabled by default in Windows Vista, you must run 'bcdedit -debug on' and reboot to enable it.”"

    Thanks in advance!

    Anyone can help me?


    Friday, March 30, 2012 7:25 AM

Answers

  • If you are on 64 bit OS run 64 bit debugger not 32 i.e. if you are using windbg use on that is there in x64 folder not in x86.

    run your debugger with administrative privilege (Run as administrator)

    On elevated command prompt i.e. command prompt opened with administrative privilege run the following command

    bcdedit /debug on

    to confirm again run bcdedit and you will see "debug yes"

    reboot and you are done.

    Friday, March 30, 2012 7:43 AM

All replies

  • Did you try 'bcdedit -debug on'? Enable it from elevated cmd. Also run windbg from elevated cmd.

    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Friday, March 30, 2012 7:38 AM
  • If you are on 64 bit OS run 64 bit debugger not 32 i.e. if you are using windbg use on that is there in x64 folder not in x86.

    run your debugger with administrative privilege (Run as administrator)

    On elevated command prompt i.e. command prompt opened with administrative privilege run the following command

    bcdedit /debug on

    to confirm again run bcdedit and you will see "debug yes"

    reboot and you are done.

    Friday, March 30, 2012 7:43 AM