Unable to access SI service from application.


  • Hi,

    I have installed SI as an stand alone.

    When i access SI Service (http://localhost/StreamInsight/SIInstance) from Event Debugger, that install in same SI Server, its accessible.

    When i try to access from c# application, which is on different machine, using below code:

    EndpointAddress endpointAdd = new EndpointAddress(
    using (var server = Server.Connect(endpointAdd))
      string AppName = "TestApp";
      if (server.Applications.ContainsKey(AppName))
      var app = server.CreateApplication(AppName);
      //Rest of code ...

    giving me an error

    "The HTTP request is unauthorized with client authentication scheme 'Anonymous'. The authentication header received from the server was 'NTLM'."

    Is there any specify permission that i am missing or what is the correct approach?

    Wednesday, July 03, 2013 6:27 AM

All replies

  • From the MSDN documentation:
    The installation process creates a user group, named according to the instance name. For an instance named "MyInstance", the user group is named "StreamInsightUsers$MyInstance". Only users in this group can connect to a published StreamInsight server. For more information about publishing a server, see Publishing and Connecting to the StreamInsight Server.

    Make sure the user that is running the C# application on a different machine is in the StreamInsight users group.

    Wednesday, July 03, 2013 4:20 PM
  • I ensured that the users are listed in the user group.

    Here is the specific error message that I am getting when I try to run the test application. Is there any particular setting in IIS that I need to worry about?

    Wednesday, July 03, 2013 5:41 PM
  • First, can you access the instance from the same machine using your custom C# application?

    Second, are both machines on the same domain? And is the user account that the console application is running under must be in the StreamInsight users group.

    Third, I wonder if this may be something in your internet settings. Have you tried putting the StreamInsight machine's name into the Trusted Sites zone?

    DevBiker (aka J Sawyer)
    Microsoft MVP - Sql Server (StreamInsight)

    Ruminations of

    If I answered your question, please mark as answer.
    If my post was helpful, please mark as helpful.

    Monday, July 08, 2013 3:18 PM