none
SQL Server Firewall issues with SQL Server Management Studio

    Question

  • I am using both SQL 2008 and SQL 2016 (which is my main server) and for the life of me I can't figure out the firewall issues.

     

    I have two local servers on my network and I am using the SQL Server Management Studio (2016) on my desktop and I have TCP and UDP ports 1433 and 1434 open to inbound and outbound traffic on both servers.

     

    If I shut down the firewall on both of the servers I can connect fine, if I bring it back up I can't connect and it just times out.

    The SQL Server set-up gives me a warning about a firewall, but I have opened up those ports, plus 2382, 2383, 4022, and 135 on both inbound and outbound and still nothing. 

    I am sure this is easy for everyone else, but I just need help with this. 



    Wednesday, March 8, 2017 5:42 PM

Answers

All replies

  • Are they default instances or named instances? Can you post your specific error message?

    There's a big list of steps to help with this in the documentation here:

    https://msdn.microsoft.com/library/mt750266.aspx?f=255&MSPPError=-2147217396

    In the firewall settings, have you tried to "Allow an app or feature through the Windows Firewall" and added SQL Server (sqlservr.exe)?

    Thanks,
    Sam Lester (MSFT)


    https://blogs.msdn.microsoft.com/samlester/

    Twitter - @SQLSamLester

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Saturday, March 11, 2017 11:20 AM
    Moderator
  • What is the exact error message you are getting when you try to connect? If it is an instance you may need to enable the browser server, restart SQL and open up port 1434 for inbound communication.
    Saturday, March 11, 2017 11:53 AM
  • The error message was "The Network Path was not found".  When I turned off the Firewall I could connect fine.
    Monday, March 13, 2017 4:40 PM
  • In the firewall settings, have you tried to "Allow an app or feature through the Windows Firewall" and added SQL Server (sqlservr.exe)?


    I did a named instance.

    I did the above on the "SERVICE" itself and it worked, but I shouldn't have to do this with SQL.  It should just ask me if I want to open up the ports and allow me to do it.   I instead added the ports manually and that wasn't good enough.  

    If Microsoft is not going to open the ports for us, then they should give us the ports to open so we know what we need to do.  Right now the information about the ports on the Internet is not complete and thus you have to do what you suggested.  Thant's not good enough for a half a trillion dollar software company. 

    You guys need to do better. 


    Monday, March 13, 2017 4:45 PM