locked
Custom project deployment issue RRS feed

Answers

All replies

  • Hi,

    The link for custom project type was too old, see this link for the newest tutorial.

    http://msdn.microsoft.com/en-us/library/cc512973.aspx

    To diagnose whether the project type was get integrated into visual studio, please follow the following two steps.

    1.    Check whether the package and the project was registered properly. Please open the regedit, check HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Projects, check whether you project factory guid is in this nodes. If you find your project factory guid click the node, you will find a value name is package and the value data is a guid in the right guid. This is the package guid. You could find it in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Packages.

    2.    The project template may not properly installed. Find your simplePoject.zip and then place it in C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\ProjectTemplates.

    Then in the command line, run “devenv /installvstemplate” and “devenv /setup”.

    3.    Check whether your ProvideProjectFactoryAttribute is right.

    Thanks

    Chao

    Thursday, July 1, 2010 12:40 PM
  • First, I want to thank you very very much for your response, but I want to ask a question:

    In step2 you mentioned above, how do I install project template step by step ?

    Could you please provide me with detailed steps about step2 ?

    I want any tutorial talking about deploying the new project system.

    Here are steps I walked through:

    1. I followed the steps in Walkthrough part1

    After finished, I run the package in debug mode (F5 experimental hive)

    The new project (SimpleProject) appears in the new project dialog.

    I used the package load analyzer and every thing are validated successfully (PLK, dependency)

    2. I followed the steps in Walkthrough part2

    But,

    part2 doesn't provide steps for deploying SimplePackage project using WIX or Setup project.

    This is the remaing part that I want more clarification about.

    Thanks again for your response.

     

    • Marked as answer by Chao Kuo Monday, July 5, 2010 3:10 AM
    • Unmarked as answer by Chao Kuo Monday, July 5, 2010 3:10 AM
    Thursday, July 1, 2010 4:27 PM
  • Hi, John

    The part1 and part2 of the walkthrough told you the steps of creating a simple project type, and did not tell you the steps of deploying a package.

    In my previous post, I have mentioned the project template development.

     The project template may not properly installed. Find your simplePoject.zip and then place it in C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\ProjectTemplates.

    Then in the command line, run “devenv /installvstemplate” and “devenv /setup”.

    So you just need to do the steps in your wix or setup.

    For package deploying, I have replied you in this link http://social.msdn.microsoft.com/Forums/en-US/vsx/thread/91402cde-f51a-4a2d-9fef-7be8f05cb7c2

    And for the steps of deploying template in VS2008 and VS2010, this link could help.

    http://social.msdn.microsoft.com/Forums/en-US/vsx/thread/736582a2-8a38-4486-bac5-37c55c4ad09c

    Thanks

    Chao

    • Marked as answer by CenaJohn Monday, July 5, 2010 11:19 AM
    Friday, July 2, 2010 6:35 AM