locked
Izenda sql server alert message RRS feed

  • Question

  • Hello,

    We have integrated login in our environment. We are using sql server and active directory for login. We are using one ERP called Jenzabar. I can login with all its application without any glitches except one new application(Izenda) that we have installed last week.

    I already test it out on my test server. I never get this kind of email message.But when I installed izenda on my production, I am getting following message.

    When I am trying to login to that system, I can login, but I am getting one alert message on my email list :

    Login failed for user 'mesatc\jenzatech'.Reason: Attempting to use an NT account name with SQL Server Authentication.I am also attaching sql logs that I am getting.

    " Login failed for user 'mesatc\amber'. Reason: Could not find a login matching the name provided"

    I am also attaching sql server alert email message that I am getting:

    DATE/TIME:      2/9/2017 10:18:25 AM

    DESCRIPTION:    Login failed for user 'mesatc\jenzatech'. Reason: Attempting to use an NT account name with SQL Server Authentication.

    DATE/TIME:      2/9/2017 10:15:55 AM

    DESCRIPTION:    Login failed for user 'mesatc\amber'. Reason: Could not find a login matching the name provided.

    Do you ever had this kind of situation before?

    How can I get rid of this alert email message?

    Thanks


    Virtual Reality

    Thursday, February 9, 2017 5:25 PM

All replies

  • How is the application trying to connect? It looks like the application is trying to use SQL authentication but is using a windows account.

    For 'mesatc\jenzatech' - can you post the connection string for the app here?

    For 'mesatc\amber' - it looks like there is no login created in SQL Server for this login.

    You are getting emails generated on login failures. This is likely not coming from SQL Server.

    Thursday, February 9, 2017 5:40 PM
  • <?xml version="1.0" encoding="UTF-8"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <configSections>
        <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
        <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
      </configSections>
      <connectionStrings>
        <add name="DefaultConnection" connectionString="Data Source=datasourcename;Initial Catalog=Productiondb;UID=username;PASSWORD=Password;MultipleActiveResultSets=True" providerName="System.Data.SqlClient" />
        <add name="Jenzabar.Ex.Configuration.Service.Properties.Settings.exdb" connectionString="Data Source=datasourcename;Initial Catalog=Productiondb;MultipleActiveResultSets=True" />
      </connectionStrings>
      <appSettings>
        <add key="webpages:Version" value="3.0.0.0" />
        <add key="webpages:Enabled" value="false" />
        <add key="PreserveLoginUrl" value="true" />
        <add key="ClientValidationEnabled" value="true" />
        <add key="UnobtrusiveJavaScriptEnabled" value="true" />
        <add key="DomainName" value="domainname" />
      </appSettings>
      <system.web>
        <customErrors mode="Off" />
        <compilation debug="false" targetFramework="4.5.1" />
        <authentication mode="Forms">
          <forms loginUrl="~/Account/LogOn" timeout="15" name=".ASPXAUTH_Izenda" />
        </authentication>
        <pages controlRenderingCompatibilityVersion="4.0">
          <namespaces>
            <add namespace="System.Web.Helpers" />
            <add namespace="System.Web.Mvc" />
            <add namespace="System.Web.Mvc.Ajax" />
            <add namespace="System.Web.Mvc.Html" />
            <add namespace="System.Web.Optimization" />
            <add namespace="System.Web.Routing" />
            <add namespace="System.Web.WebPages" />
          </namespaces>
        </pages>
        <!-- This approach to adding HTTP Modules is needed by IIS on the test server. -->
      </system.web>
      <system.webServer>
        <!-- This approach to adding HTTP Modules is needed by IIS Express used by Visual Studio. -->
        <validation validateIntegratedModeConfiguration="false" />
        <modules runAllManagedModulesForAllRequests="true" />
        <handlers accessPolicy="Read, Script">
          <remove name="ExtensionlessUrlHandler-ISAPI-4.0_32bit" />
          <remove name="ExtensionlessUrlHandler-ISAPI-4.0_64bit" />
          <remove name="ExtensionlessUrlHandler-Integrated-4.0" />
          <add name="ExtensionlessUrlHandler-ISAPI-4.0_32bit" path="*." verb="GET,HEAD,POST,DEBUG,PUT,DELETE,PATCH,OPTIONS" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32" responseBufferLimit="0" />
          <add name="ExtensionlessUrlHandler-ISAPI-4.0_64bit" path="*." verb="GET,HEAD,POST,DEBUG,PUT,DELETE,PATCH,OPTIONS" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness64" responseBufferLimit="0" />
          <add name="ExtensionlessUrlHandler-Integrated-4.0" path="*." verb="*" type="System.Web.Handlers.TransferRequestHandler" preCondition="integratedMode,runtimeVersionv4.0" />
        </handlers>
            <directoryBrowse enabled="false" />
            <defaultDocument>
                <files>
                    <clear />
                    <add value="Default.asp" />
                </files>
            </defaultDocument>
            <httpErrors>
                <clear />
            </httpErrors>
      </system.webServer>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="System.Web.WebPages.Razor" publicKeyToken="31bf3856ad364e35" culture="neutral" />
            <bindingRedirect oldVersion="0.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="0.0.0.0-5.1.0.0" newVersion="5.1.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral" />
            <bindingRedirect oldVersion="0.0.0.0-6.0.0.0" newVersion="6.0.0.0" />
          </dependentAssembly>
        </assemblyBinding>
        <legacyHMACWarning enabled="0" />
      </runtime>
      <entityFramework>
        <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework" />
      </entityFramework>
      <uri>
        <idn enabled="All" />
        <iriParsing enabled="true" />
      </uri>
    </configuration>

    Hello,

    Above, I have attached web.config file.that might be helpful. We have one global.asax file.If you need I can attach it for you.

    We have group for particular member. mesatc\amber is part of mcn_registrar group .

    We don't have her account as a name as a mesatc\amber.she is in mcn_registrar group.


    Virtual Reality

    Thursday, February 9, 2017 5:53 PM
  • Question:

    Izenda groups in active directory are:MCN_IZADMIN,MCN_IZDELETER,MCN_IZOVERWRITE,MCN_IZDESIGNER

    Do I need to create sql login for this account in sql server? 

    For Izenda , we have created different groups in active directory.

    Do I need to create a sql server user and login as mcn_izadmin in sql server to stop this alert message?


    Virtual Reality



    • Edited by VR16 Thursday, February 9, 2017 7:01 PM
    Thursday, February 9, 2017 6:27 PM
  • Your connection string or options in the connection string are wrong.

    When connecting to SQL Server and passing a Windows AD login, you either check a box which says "Windows Account" or pass a command line which indicates the login is a Windows AD account, not a SQL account.

    • Proposed as answer by Naomi N Thursday, February 9, 2017 11:12 PM
    Thursday, February 9, 2017 6:32 PM
  • It looks like the accounts in this configuration file are sql authentication accounts, but it is difficult to say.

    Can you do the following, right click on SQL Server, properties, and then security and make sure SQL and windows Authentication mode is selected. You will need to restart SQL Server service if it is not. Ensure failed logons is selected.

    Next in the security folder right click on the account 'mesatc\jenzatech' and make sure it is a windows Login. I suspect you have it configured as a SQL login. The account display here is a windows login.



    Thursday, February 9, 2017 6:36 PM
  • Yep.  For Windows Integrated Auth. Connection string should be something like

    
    
    <add  name="Jenzabar.Ex.Configuration.Service.Properties.Settings.exdb" 
       connectionString="Data Source=datasourcename;Initial Catalog=Productiondb;MultipleActiveResultSets=True;Integrated Security=true" /> 

    Then configure the IIS Application Pool to use the desired Windows account.

    David


    Microsoft Technology Center - Dallas

    My Blog

    Thursday, February 9, 2017 6:37 PM
  • Hello,

    I have same configuration that you have suggested me..I am attaching screenshot for that,


    Virtual Reality

    Thursday, February 9, 2017 6:51 PM
  • I added integrated Security=true in my web.config.But doesn't work...

    Thanks


    Virtual Reality

    Thursday, February 9, 2017 6:58 PM
  • Would you please elaborate me following line:

    Then configure the IIS Application Pool to use the desired Windows account.

    Thanks


    Virtual Reality

    Thursday, February 9, 2017 7:00 PM
  • This should be covered in the installation guide for your new application, or by your application vendor's implementation and support people.

    see: IIS Application Pool

    David


    Microsoft Technology Center - Dallas

    My Blog

    • Proposed as answer by Naomi N Thursday, February 9, 2017 11:13 PM
    Thursday, February 9, 2017 7:29 PM
  • Please see:

    https://blogs.msdn.microsoft.com/ericparvin/2015/04/14/how-to-add-the-applicationpoolidentity-to-a-sql-server-login/

    Thursday, February 9, 2017 8:06 PM
  • I also put a ticket to my ERP support. They replied me that

    It is software issue from ERP side. It is not microsoft issue.

    Thanks for your efforts. I appreciated.


    Virtual Reality

    Friday, February 10, 2017 10:26 PM