none
View svc in browser - HTTP Error 404.3 - Not Found RRS feed

  • Question

  • I have Windows server 2008 IIS 7 and net framework 4 installed. I am trying to deploy some SL application, but run into a problem . After this suggestion i came nowhere.

    I finally try to acces svc file and i get error:

    HTTP Error 404.3 - Not Found

    The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

    I found this link and run ServiceModelReg -i. I call iisreset (just in case), but i get the same error.

    Edited:

    The problem is that ServiceModelRef register with framework 2.0, but i need framework 4.0.

    Everyone sugest running ServiceModelReg -i but i need for framework 4.0!

    Tuesday, May 18, 2010 12:29 PM

Answers

All replies

  • I found this but on point 8.:Type %SystemRoot%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll into the Executable: text box.

    i changed it to v4.0.30319.

    Now i have MyComputerName (in iis manager) handler mapping this 2 svc extensions.

    But i am still seeing this error.

    Tuesday, May 18, 2010 1:02 PM
  • It should be set on the side. I don't know why, but it works for me.
    • Marked as answer by Makla1243 Tuesday, May 18, 2010 2:39 PM
    Tuesday, May 18, 2010 1:33 PM
  • ServiceModelReg exists for all frameworks, under

    %windir%\Microsoft.NET\Framework[64]\[Framework version]

    Another possible cause of this error is that your app may be running in a .NET 2.0 AppPool instead of .NET 4.0.  Earlier this evening I was seeing the same error message for my web service; the fix was to switch the AppPool from .NET 2.0 to 4.0.

    • Proposed as answer by crimbo Monday, September 10, 2012 5:31 AM
    Monday, September 10, 2012 5:31 AM