none
Regarding problem with the visual studio 2012

    Question

  • I have problem with Visual Studio 2012 Professional, Whenever i want to add (External class library) .dll as reference in my windows application project then when I click on Browse button then open dialogue box will not be shown for selecting the .dll file, it means that browse button may not work properly. Then what should i do please tell me.
    Wednesday, May 25, 2016 9:44 AM

All replies

  • Hi Vishal,

    Based on your description, your case more related to Visual Studio 2012 Professional Browse button issue, I will help move your case to VS general forum for better support.

    Best regards,

    Kristin


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, May 26, 2016 6:47 AM
  • Hi Vishal7799,

    According to your description, you mean there doesn't have any dlls listed in the "Select the files to reference..." dialog box, which shown as below screenshot, is it right?

    Please confirm whether there has dlls exist in the path that you choose first. Then check the File type behind the File name, please choose it as Component Files(*.dll;*.tlb;*.ol...) as above screenshot shows.

    In addition, please check whether you have installed the latest update for your Visual Studio2012. The latest update for Visual Studio 2012 should be Update 5.

    If misunderstanding, please provide a screenshot to help us understanding your problem. Thanks.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, May 26, 2016 8:30 AM
    Moderator
  • Hello Weiwei,

    Please find below screen-shot for better understanding. This problem occurs when we add external .dll file as reference into our project , that means right click on references(References<->Add References) then on add references window this problem occurs.

    Best Regards,

    Vishal.
    Monday, May 30, 2016 4:44 AM
  • Hello Weiwei,

    Please find below screen-shot for better understanding. This problem occurs when we add external .dll file as reference into our project , that means right click on references(References<->Add References) then on add references window this problem occurs.

    Best Regards,

    Vishal.

    I don't see the screen-shot. Where is it?
    Monday, May 30, 2016 5:15 AM
  • https://plus.google.com/117654103905911791471/posts/JxzWX8iw6k1

    Find out on to this link...

    Monday, May 30, 2016 6:03 AM
  • Hi Vishal,

    According to the screenshot, do you mean after you click the Browser button, there doesn't have any dlls listed in the pop up Select the files to Reference dialog or there doesn't have any dlls in the References Manager dialog?

    If you mean there doesn't have dlls in Select the files to Reference dialog, please open the path in File system to check whether there has any dlls in this path first. If there has dlls in that path, please check the file type that I mentioned in my first reply. Please tell us the check result, thanks.

    If you mean there doesn't have dlls in References Manager dialog, it is a normal action if you don't add references through Browser recently. Because the Reference Manager in Browser tab will show the dlls that referenced recently.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, May 31, 2016 1:10 AM
    Moderator
  • Dear Weiwei,

                      When we Click on Browse button then it could not happen anything that means open dialogue box can't open after we click on Browse (Browse button is not working).

    Thanks and Regards

    Vishal

    Tuesday, May 31, 2016 6:41 AM
  • Hi Vishal,

    Thanks for your explain your issue for me patiently.

    Does this problem occurs when installing the Visual Studio or after using for a while?

    If occurs after installing, please check whether you have installed the latest update first and then please try repair your Visual Studio to check whether there has any problem when installing.

    If occurs after using for a while, please try with following steps to troubleshoot this problem.

    1. Run Visual Studio as administrator to ensure all operations have enough permission.
    2. Run Visual Studio in safe mode to prevent all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Close all third part programs when running Visual Studio, such as antivirus.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, June 1, 2016 2:39 AM
    Moderator
  • Thanks brother......, will try and get back to you soon..........:-)

    • Edited by Vishal7799 Wednesday, June 1, 2016 4:12 AM
    Wednesday, June 1, 2016 4:11 AM
  • Hi Vishal,

    I will waiting for your response for the test result. All above steps can help us check what's the possible reason for this problem.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, June 2, 2016 1:09 AM
    Moderator
  • Hello Weiwei,

    We have tried all the above mentioned three ways, also Visual Studio repair completed successfully.

    but nothing happens.

    Best Regards,

    Vishal 

    Thursday, June 2, 2016 11:07 AM
  • Hi Vishal,

    Please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio. If you don't find this file in that path, please turn on the /Log switch for your Visual Studio and then operate your Visual Studio again to check whether there has any error information in the ActibeLog.xml file.

    And please make sure you have installed the Update 5 for your Visual Studio again. If have installed and there doesn't have error information in ActiveLog.xml, please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, June 3, 2016 1:38 AM
    Moderator