none
unable to install .net framework 2.0 updates KB2972105 & KB2978124 in windows 2003 RRS feed

  • Question

  • unable to install .net framework 2.0 updates KB2972105 & KB2978124 in windows 2003 server.We are getting following error like ->

    "None of the products that are addressed by this software update are installed on this computer. Click Cancel to exit setup."

    Do we have any workaround for this

    Tuesday, May 12, 2015 10:29 AM

Answers

All replies

  • Please read through these:

    https://support.microsoft.com/en-us/kb/2972105/

    https://support.microsoft.com/en-us/kb/2978124/

    Note especially the sections entitled "How to obtain help and support for this security update".

    You can also check to see if your .NET 2.0 SP2 is properly installed with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 2.0 selected, then observe the first 12-15 lines of the tool log to see the .NET versions recognized. Then check the last 12-15 lines of the log for the .NET 2.0 test app result. A return code != 0 means the framework is corrupt.

    If your 2.0 SP2 is OK, pursue the help and support links I provided above.

    Tuesday, May 12, 2015 1:14 PM
  • Hi Murali Devarasetty,

    For your problem, I think you can use the .Net Framework Verification Tool to check whether the .NET Framework 2.0 has installed on your machine or not.
    Please refer to the link: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    You can run this tool, in the dropdown list, if it exists .NET 2.0, then you can repair it. You can find the log file in the %Temp% folder, check the last 15 lines of the log for the .NET 2.0 test app result. A return code != 0 means the framework is corrupt. If it is corrupted, you can provide the error code for us to do the further research.

    If .NET 2.0 doesn’t exist in the dropdown list, it means that .NET 2.0 isn’t installed on your machine. You may need to install it as MVP has already mentioned.

    Hope this information is helpful.

    Best Regards,
    AngeliaLi

    Wednesday, May 13, 2015 5:52 AM
  • Hi AngeliaLi,

    Thanks for your comments. We have used " .Net Framework Verification Tool" and it verified .NET 2.0 sucessfully(I can find in log "Process 'Netfx20TestApplication.exe' exited with return code 0").

    But not able to apply those updates(KB2972105 & KB2978124).Will this be due to any other dependency?

    Thanks,Murali

    Wednesday, May 13, 2015 9:56 AM
  • In my reply above, I referred you to sources of help with these KB's:

    Please read through these:

    https://support.microsoft.com/en-us/kb/2972105/

    https://support.microsoft.com/en-us/kb/2978124/

    Note especially the sections entitled "How to obtain help and support for this security update".

    As you have verified your .NET Framework 2.0, this is not a .NET setup issue.

    Wednesday, May 13, 2015 1:43 PM
  • @Murali,

    I agree with pvdg42 here that your problem may related to the two updates themself. You may need to ask for help by follow his advice or consult on the following forum:

    http://answers.microsoft.com/en-us/windows/forum/windows_update?tab=Threads

    Best regards,



    Barry
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, May 15, 2015 8:27 AM
    Moderator