none
MSDN Virtual Labs: "No Connection" message RRS feed

  • Question

  •  

     Hi,

     

           I am facing "No Connection" problem while connecting to labs. I am behind corporate proxy server. Nevertheless I provide all proxy server details in the "No Connection" dialog box. Still I am not able to connect to the labs. Our 443 port is also open. Also our system administrator has tried various options but still problem exists. Can someone please tell what else could be the problem? Thanks in advance.

     

    P.S.:  I have already looked at the link in this forum. But unfortunately it was not helpful.

    Tuesday, August 7, 2007 7:40 AM

Answers

  • This is a bit difficult to troubleshoot with the information we've got, but I've got a couple of thoughts.

    First, can you download the VMRC control from the site?  It, too, is an ActiveX control, so if you can't download the VMRC control that indicates that you might have a corporate permissions issue with the downloading of ActiveX controls.

    Second, see that port 443 is not only open though the corporate proxy server, but on the local firewall (if enabled) as well.

    Third, ensure that other devices or software that might listen to port 443 have been disabled.  For example, ACE for VMWare running might interfere with the connection.


    Finally, the ActiveX control is only able to perform basic authentication when working with proxy servers.  Though I've never seen it myself, I've heard of cases where the client network is running ISA server with anonymous connections disabled.   Because of this, you can't get NTLM authentication.  This might be something to look at as well.


    Hope that one of these options helps you out.

    Rah.

    -plc

    Monday, February 4, 2008 4:07 PM

All replies

  • This is a bit difficult to troubleshoot with the information we've got, but I've got a couple of thoughts.

    First, can you download the VMRC control from the site?  It, too, is an ActiveX control, so if you can't download the VMRC control that indicates that you might have a corporate permissions issue with the downloading of ActiveX controls.

    Second, see that port 443 is not only open though the corporate proxy server, but on the local firewall (if enabled) as well.

    Third, ensure that other devices or software that might listen to port 443 have been disabled.  For example, ACE for VMWare running might interfere with the connection.


    Finally, the ActiveX control is only able to perform basic authentication when working with proxy servers.  Though I've never seen it myself, I've heard of cases where the client network is running ISA server with anonymous connections disabled.   Because of this, you can't get NTLM authentication.  This might be something to look at as well.


    Hope that one of these options helps you out.

    Rah.

    -plc

    Monday, February 4, 2008 4:07 PM
  • Well, I've tried all of the above and still get presented with a blank screen upon following the View Online link for a Virtual Lab for which I've registered. I wish I got as far as a "No Connection" message, at least then I'd be getting some sort of feedback.

     

    Getting source on the blank page (using IE7) reveals nothing more than a doctype and empty body content.

     

    If the Virtual Machine Remote Control app is required, then why isn't this stated anywhere from the Virtual Labs homepage? In fact, there's nary a helpful link in sight for troubleshooting issues.

     

    Any other advice? I'd dearly love to see what these VLs are all about.

    Thursday, April 3, 2008 3:32 AM
  • I've never seen that issue.

    What Virtual Lab are you attempting to run? 

    Where, exactly is the View Online link?

     

    Let me know, and I'll see if I can duplicate your issue.

     

    In the meantime, let's see if you can get into a lab that is working correctly for me.

     

    Try registering for the following lab:

    http://msevents.microsoft.com/CUI/WebCastEventDetails.aspx?EventID=1032365360&EventCategory=3&culture=en-US&CountryCode=US

     

    After going through registration, you'll eventually come to a page titled Thank You For Registering!

     

    On this page is the button Click here to enter the Virtual Lab.

     

    What happens when you click that button?

     

    You should be directed to a page that informs you that the lab is being built.

    This lab building should take about two to three minutes.  During this time, the virtual machines are being brought online.

    Once the lab is built, you should see a Start your lab button.  Clicking this button should pop up another IE window with the virtual lab inside.

     

    Let me know exactly where this process breaks down for you, and hopefully, we'll figure out what's going wrong.

     

    Thanks,

    -Patrick

     

    Friday, April 4, 2008 5:21 PM
  • Two more questions for you:

     

    1)  Are you behind any type of corporate firewall?

    2)  Do you have Silverlight installed? 

     

    Friday, April 4, 2008 5:25 PM
  • Yes, I am behind a corporate firewall and I have verified with the network team that authentication and access through port 443 should be no problem.

    Silverlight shoul dbe installed but it's hard to verify. This isn't made any more easy by the fact that the Install Silverlight links at the top of almost MS site page give a 404 error.

    I am off-site this week and unable to attempt registration for the Lab provided above but I don't see why it should be different than any of the others (unless they expire?).

    I have tried registering for several of the SharePoint labs. The View Online link appears after successful registration.

    I actually got one step further using FireFox and was able to see the download link for the Lab PDF and download it but was not able to get any further due to the ActiveX requirement.

    I also manually downloaded this control for IE7 but have had no luck.

    Will let you know more next week as I only have access to Apple PCs at present(!). Smile
    Monday, April 7, 2008 10:59 PM
  • Hm.  I never get to the 'View Online' link.

     

    On the page after registration I don't see that link.  Instead, I see a button that says...

    Click Here to Enter the Virtual Lab.

     

    I wouldn't worry about the silverlight issue.  I was just curious, and upon further research, I doubt that is the issue.

     

    When you get it, could you send me a link (or the name) of the lab you were trying to access?

    And if you feel like it, when you return try out the first of these:

     

    http://technet.microsoft.com/en-us/office/sharepointserver/bb512933.aspx

     

    Cheers, and enjoy your travels,

    -plc

     

    Tuesday, April 8, 2008 4:12 PM
  • OK. Back in the office and I have tried again using the top two Labs from the URL you provided. Namely:

    • Microsoft Office SharePoint Server 2007 Installation and Configuration (ID:1032337119)
    • Search Administration and Customization in Microsoft Office SharePoint Server 2007 (ID:1032346002)
    1. I register for the event.
    2. Click Continue.
    3. Confirm my details.
    4. Click the "Click here to enter the Virtual Lab" link (the text differs on different labs).
    5. Get a blank screen. Browser status bar says Done. No errors, no prompts or dialogs. Nada.
    6. I then go and check the My Events page for "My Microsoft Events, Webcasts, and Virtual Labs" and see that are no events listed.

    I'm now completely out of ideas. The fact that it's working for other people suggests this is probably a network problem at my end. I wish I knew what so I could change it.

     

    NB: I just went through this same process with a TechNet Virtual Concierge consultant who encountered exactly the same problem. The problem has now been escalated to tech support internally. At least I'm not alone.

     

    Regards,

    Paul

    Thursday, April 17, 2008 12:40 AM
  • Good to know the problem is reproducable.

    What IE7 Security level are you running at?  (Medium-high, high, or custom)

     

    Also, lets try this:

     

    1)  Ensure you have JavaScript enabled.

    2)  Download the VMRC ActiveX control manually.  You can get the ActiveX control here:  https://www.microsoft.com/resources/virtuallabs/installactivex-technet.aspx?LabId=b1d0bba4-b85e-47ff-ade4-cec176704e3b

    3)  Ensure you have ActiveX contols active in your browser.

     

    Was the Technet Virtual Concierge able to repro this on their own system? 

     

    We'll figure this out. 

    -colacurcio

     

    Thursday, April 17, 2008 3:53 PM
  • Could you try two more things for me?

     

    Go through the registration step. 

    When you get to the 'Thank you for registering' page, click the My Events link.

     

    What do you see listed in the events box under the compressed

    Show/Hide Profile Information

     

    link?  (Beneath that link, not in it)

     

    If you see nothing, we've probably got a problem with the security settings on IE. 

    If you see a box that says 'No Records found' then we've got a registration issue.

     

    Secondly, I'd like to know if anyone else can get these labs to work on their machines.

    Has anyone else in your network tried this out?

     

    If they have, and can access the labs, its something specific to your machine.  In that case, I'd un-and-reinstall the ActiveX control referenced in the previous post.

     

    -Patrick

    Thursday, April 17, 2008 4:21 PM
  • The concierge ran into exactly the same problem which is why she decided to escalate it. Smile

    I'd already checked and tried everything mentioned above but to no avail.

    The My Events list is indeed empty. Sad

    I can't really begin asking colleagues to try it on other machines but the fact that the concierge had the same issue suggests I'm not alone.

    I'll wait and see what they come back with and, if it's resolved, post the solution back here.
    Friday, April 18, 2008 7:21 AM
  • Just to be clear,

    After confirming your registration, if you click the my events link, you see nothing under

    show hide profile information.

     

    Normally, there should be a two colored box area there with three tabs, Registered Events, Bookmarked Events, and History

     

    You don't even see that box, correct?

    -plc

     

     

    Friday, April 18, 2008 3:24 PM
  • I an see the tabs but no events listed in any of them.
    Saturday, April 19, 2008 3:58 AM
  • When you get to the blank page, could you right-click on it, and click Properties?

    I'd like to know what the address is for that page.

    -plc

    Sunday, April 20, 2008 4:31 PM
  • The link URL you already know but I can't get the final URL without going through the process again. Will check tomorrow.

    I can tell you that the page source displays nothing in the body though.
    Monday, April 21, 2008 9:11 AM
  •  

    FYI - the final URL is https://www.microsoft.com/resources/virtuallabs/entry.aspx?LabId=4d996820-5029-40aa-9dd8-ea035acab50f&Referer=Technet which seems correct.

     

    One interesting thing to note was that this time the event got added to My Events but still no success in viewing it. And still no response from TechNet support(!). Grr.

    Tuesday, April 22, 2008 6:20 AM
  • I'm experiencing the same perplexing problem while trying to access the labs. Yesterday I also tried accessing a lab using Firefox rather than IE 7 and was surprised to get farther than I had with IE. I got as far as the system check, and then get the error that "this site requires IE6.0 or above." Well, this let me know that there's something more at the address than what I was seeing, which, like you, was only an empty page with nothing in the source except a header and empty body.

     

    So today I grabbed a laptop (also IE7) and tried -- I was able to get in! I went through every IE setting and add-in and everything is the same. The only thing I can think of now is that I've run a virtual machine on the desktop, but never on the laptop. How about you? Could it be a VM setting?

     

    Tuesday, April 22, 2008 5:40 PM
  • Hey RebRed,

     

    This process seems to be getting stuck on the system check page.

    Perhaps you've got an old version of the VMRC control and the script behind the page doesn't know how to deal with it.  Is Virtual Server your virtualization engine?  If so, which version are you using?

     

    Could you check what version you have in your IE7?  You can find this through clicking Tools | Internet Options | Programs | Manage add-ons.

     

    The Microsoft Virtual Server VRMC Advanced Control should be one of those lists.

     

    Would you mind deleting that control and reinstalling it?  You should be able to download it through going through the Virtual Lab registration process. 

     

    Let me know what you see when you get to the System Check page.

     

    I'll look into the Virtual Server settings to see if I can duplicate this by placing local restrictions on the VMRC control.

     

    Thanks,

    -plc

     

    Tuesday, April 22, 2008 6:05 PM
  • Definitely no VMs on this box. It's a fairly recent clean install.

    I downloaded the most recent version of the VMRC manually which I don't think is even required for the labs. It just gets curiouser and curiouser.

    Was you laptop connected to your work's LAN when you managed a successfully entry, or did you connect remotely?

    I still can't help but think this is a firewall/network issue but I'll be damned if I can work out exactly what is causing it.

    The fact that the TechNet concierge followed the same steps as I did and also reached a blank page suggests this is not an isolated problem. If only a TechNet staffy could follow up on this with some vigour we might reach a resolution.

    Three cheers for tech support! Big Smile
    Wednesday, April 23, 2008 8:26 AM
  • I am having issues also coming from the Eval '08 pages. I ma trying to demo the items on that page.

     

    The problem I am having is in earlier step.

    The system requirements page. Says Java and the other requirment is fine. But the VRMC active x control is not installed. I click on it and get to a page like the link you provided above.

     

    But the active x control does not begin to download. The images for Install Active X control "What are the risks" and Infomration bar help do not load. There is no clickable link anywhere on the page and no file popup appears to Run or Save.

     

    I have tried from many refering pages all to the same result. I have searched on VRMC to download it outside this process and found no references on MSDN or Microsoft.

     

    Active X is enabled in settings.

    Block Pop ups are turned off.

    Other Active X controls are downloading fine. Tested an Active X acquisition from another site.

     

    Any suggestions.

    Monday, April 28, 2008 4:28 PM
  • At the very top of the page (below your page tab(s)) there is a thin, one line yellow background area with the text This website wants to install the following add-on 'Virtual Machine Remote Control Advanced ActiveX ...' from 'Microsoft Corporation'.  If you trust the website and want to install it, click here...

     

    Do you see that strip?  It should be just above the Click here to install Silverlight link (if you don't have Silverlight installed).

     

    You should be able to click that and click Install ActiveX Control to start up the download.

     

    Let me know if you see that.  If you don't, could you chat the full name of the Virtual Lab you were trying to install?

     

    Thanks,

    -Colacurcio

    Monday, April 28, 2008 4:47 PM
  • This problem is resolved for me at last! Using IE7, I used the "Reset Internet Explorer settings" button at the bottom of the Advanced tab in Tools/Internet Options. Unbelievable - that did it. I don't know what it killed off that I couldn't get to myself through all the other means, but I think it had to do with disabling all add-ons. All I know was that I had two machines on the same switch in the same subnet, using the same software, and I could access the page with one machine, but not the other. I had reproduced all configurable internet, Flash, etc. settings from the working machine to the one that didn't display the page with no useful outcome. One click on "reset..." and I was in! Wasted time all around, but I'm glad to be able to access the labs finally. Good luck - I hope it works for you all, too.

     

    - Reb

    Tuesday, April 29, 2008 8:28 PM
  •  

    Congrats RebRed,

     

    Must have been some other type of add-on interfering.

    Very odd.  Glad your issue is resolved.  Enjoy the labs!

    -plc

     

    Tuesday, April 29, 2008 8:43 PM
  • Woo-farking-hoo! Same deal. Finally, a resolution.

     

    Now theer are only two things to do:

     

    1. Get started on this lab.

    2. Begin the slow and painful process of enabling add-ons one at a time to find the culprit.

     

    Thanks, RebRed. Who woulda thought? Smile

     

    Thursday, May 1, 2008 1:42 AM
  • Hey Tirebiter,

     

    I was able to run that lab using the URL you posted.  (So, after troubleshooting, you'll have to re-register)

     

    Here's a summary of the troubleshooting steps you should take if having difficulties:

     

    First, can you download the VMRC control from the site?  It, too, is an ActiveX control, so if you can't download the VMRC control that indicates that you might have a corporate permissions issue with the downloading of ActiveX controls.

     

    Second, see that port 443 is not only open though the corporate proxy server, but on the local firewall (if enabled) as well.


    Third, ensure that other devices or software that might listen to port 443 have been disabled.  For example, ACE for VMWare running might interfere with the connection.


    Fourth, the ActiveX control is only able to perform basic authentication when working with proxy servers.  Though I've never seen it myself, I've heard of cases where the client network is running ISA server with anonymous connections disabled.   Because of this, you can't get NTLM authentication.  This might be something to look at as well.


    Finally, you can try clicking the "Reset Internet Explorer settings" button at the bottom of the Advanced tab in Tools/Internet Options. Several people have reported this as being a solution to the no-connection issue.  You might have an IE add-on that's interfering with the registraton process or VMRC ActiveX control.

    Good luck,

    -plc

    Thursday, May 22, 2008 4:46 PM
  • access: TechNet Virtual Lab: Managing Internet Information Services 6.0

    tried 'reset' in IE6... no connection.

    what is extremely frustrating about this is that i was in and was using it this morning.

    continues to count down... grrr

    Tuesday, December 28, 2010 5:42 PM