locked
Expression Blend 3 Hangs on start. (Also unable to run Expression setup / uninstall) RRS feed

  • Question

  • I have been running Expression 3 Studio for some time without any problems on a newer Dell PC running Windows 7.

    Today, (for the first time in about a week), I tried opening a file from VS2008 in expression blend. The Blend IDE displays but the progress indicator (circle) never stopped spinning and the app went into 'not responding' according to task manager / window caption. I thought maybe something was up with Visual Studio, so I closed it and tried opening Expression Blend in an effort to load the project from Blend itself.

    Again the Blend IDE displayed and became unresponsive. The task manager showed a consistent 49-50% CPU usage for the Blend process.

    After checking the event log and some other excercises in futility I decided to uninstall. When attempting to run the setup for Blend (also tried expression studio level setup), the splash screen displays and then the installer hangs (CPU is consuming 49-50% which is similar behavior to the app).

    All other apps in Expression studio behave similarly (Web, Design, etc. all HANG on start and the process stays at a consistent 49-50% CPU usage)

    In a last ditch effort I upgraded my ATI video drivers (ATI Radon HD 3470) which did not fix the issue.

    Any direction / advice would be appreciated.

    Thanks!


    ~PuGsLY~
    Tuesday, March 23, 2010 11:27 PM

Answers

  • Problem Solved by uninstalling & reinstalling .NET 3.5 SP1 (must be done via control panel in Windows 7)

    Windows 7: Control Panel > Programs and Features > 'Turn Windows features on or off'

    1. Deselect 'Microsoft .NET Framework 3.5.1
    2. Reboot (should be required)
    3. Go back to turn windows features on/off
    4. Reselect Microsoft .NET Framework 3.5.1

    It appears that something hosed (corrupted) the .NET 3.5 Presentation DLLs. (When attaching to a hung process of EB3, I could see that it was hung on one of the presentation DLLs.) This, in addition to a non-MS Xaml tool was also unable to run, made the current dotnet 3.5 framework integrity suspect. Several coworkers in my group came in Monday with their PCs hung from a corporate update.

    I suspect that whatever update was crammed down my PC may have overwritten / corrupted these files.


    ~PuGsLY~
    • Marked as answer by pugsly75 Wednesday, March 24, 2010 6:19 PM
    Wednesday, March 24, 2010 6:19 PM