locked
Error! RRS feed

  • Question

  • Hi,

    I installed the Microsoft Robotic Studio on Windows Vista 32 bit today and I am trying to run a trial program but I keep getting this error (attached to this email). I do have Microsoft .Net Framework 3.5 SP1 installed. Can you please help me out. I would really appreciate a quick response since my projects deadline is very near. Thanks a lot.


    Error: http://img21.imageshack.us/my.php?image=errorslf.jpg

     

    Best Regards,

    Umer
    umer_wahla@hotmail.com

    Saturday, March 21, 2009 5:20 PM

Answers

  • On Vista you might have to use the httpreserve utility to reserve the ports for use by your account.

    Open a DSS Command Prompt, and then type:
    httpreserve /?

    This will display the help. It's a fairly simple utility to use. By the way, it must be run from an Administrator account, but you can grant access to non-Admin accounts.

    Trevor
    Monday, March 23, 2009 6:15 AM

All replies

  • You probably need to do one of the following:

    1. Run the DSS node as Administrator
    2. Make sure you don't have another DSS node running in the background already
    3. Make sure no other programs are using port 50000 or 50001 or whatever your DSS node uses
    4. Make sure you don't have some firewall or some kind of port protection on your desired DSS port

    -Ben

    www.coroware.com
    Saturday, March 21, 2009 7:22 PM
  •  Hey,
    Thanks alot for the reply but I am a noob and I don't know how to do the following:-
    1. Make sure you don't have another DSS node running in the background already
    2. Make sure no other programs are using port 50000 or 50001 or whatever your DSS node uses
    3. Make sure you don't have some firewall or some kind of port protection on your desired DSS port

    btw, the user account I am running it on is an administrator account so perhaps that is not the issue. Thanks again. Waiting for ur reply
    Sunday, March 22, 2009 12:04 AM
  • >  1. Run the DSS node as Administrator

    I don't know too much about vista, but i heard that you also might need to right click the application and select 'run as administrator'.

    >  2. Make sure you don't have another DSS node running in the background already

    This happens the *second* time you run your program if you forget to stop the dss node.  you'd be surprised how often this happens to me.  a restart should clear this up.

    >  3. Make sure no other programs are using port 50000 or 50001 or whatever your DSS node uses.

    If some other program on your computer is using port 50000, then DssHost can't get access and you get your error.  You can change the ports VPL uses by going to Run -> Port Settings...  and change them to something that is unused on your machine.  or if you are using C# directly, change the command line arguments on the Debug tab of the project properties in visual studio.

    >  4. Make sure you don't have some firewall or some kind of port protection on your desired DSS port

    I assume you know how to turn off any firewall on your computer.

    www.coroware.com
    Monday, March 23, 2009 2:21 AM
  • On Vista you might have to use the httpreserve utility to reserve the ports for use by your account.

    Open a DSS Command Prompt, and then type:
    httpreserve /?

    This will display the help. It's a fairly simple utility to use. By the way, it must be run from an Administrator account, but you can grant access to non-Admin accounts.

    Trevor
    Monday, March 23, 2009 6:15 AM