locked
Port 445 Blocked - Alternative? RRS feed

  • Question

  • I've confirmed that my ISP (Rogers) blocks port 445 (and a few others,) on the service I am receiving from them.  I am trying to connect my Backup software to write directly to an Azure Blob, but can't because 445 is blocked.  Is there a way to get around this as the ISP refuses to unblock?
    Monday, July 31, 2017 8:12 PM

All replies

  • If you’re writing data to Azure Blob storage (*.blob.core.windows.net) then you’ll need ports 80 (HTTP)/443 (HTTPS). Port 445, on the other hand, is meant for Azure File storage that is based on SMB protocol. If what you actually want is Azure File storage for mapping file shares, then you’ll have to work with your IT department to open port 445 outbound to Azure IP ranges
    -----------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.
    • Proposed as answer by Md Shihab Tuesday, August 1, 2017 3:08 AM
    Tuesday, August 1, 2017 3:08 AM
  • I am trying to connect my Altaro Backup software installed on an on-prem, physical machine to Azure File Storage.  I've create a file storage account, gone to Access Keys, got one of the two connection strings generated, put it into my software, hit test and it fails.  If I change the protocol from https to http, it will connect but not function as unencrypted connections are only supported from an Azure VM in the same datacenter as the storage account.  My software vendor has confirmed that the same connection string (using https) works from their location.

    I am the IT department. I can confirm that on my router, port 445,80,443 (and all other ports for testing purposes) are open for this one server.  My ISP (Rogers Cable in Canada) has confirmed they do block 445 (as well as netbios ports, 1080 and 1433/1434 SQL access/management ports) on ALL Home and SMB services - I've requested they unblock but they have told me it's not an option for the service I am subscribed to (1000Mb unlimited Ignite service, with a dynamic IP - it might be different with a Static IP, but they cripple the upload to 20Mb on that service.)  

    My hope is that after years of Microsoft encountering this (for which they even have pages devoted to listing ISPs that block this port, https://social.technet.microsoft.com/wiki/contents/articles/32346.azure-summary-of-isps-that-allow-disallow-access-from-port-445.aspx) they've introduced an alternate solution - the 2 easiest to come to mind is an alternative port or a VPN tunnel into Azure.



    Tuesday, August 1, 2017 4:09 PM
  • You might want to up-vote this feature that’s already been requested. It is under review but there are no timelines we can share.

    -----------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    • Proposed as answer by Md Shihab Wednesday, August 2, 2017 11:28 AM
    Wednesday, August 2, 2017 11:09 AM
  • I have now commented on and up-voted the feature.  I guess that is the extent of what I can do since the functionality doesn't exist currently - I will need to abandon this project for the time being.
    Thursday, August 3, 2017 3:39 PM
  • You may see the solution as a deep dive technical video at my YouTube Video,

    https://www.youtube.com/watch?v=aDB-EFpuXrQ&t=3s

    Sunday, January 20, 2019 1:14 AM
  • If you have ever been blocked using Azure Files due to your ISP's port 445, you can setup a Point to Site VPN to your Azure Files. Refer to the suggestions mentioned in the GitHub article

    Hope this helps!

    Kindly let us know if the above helps or you need further assistance on this issue.

    Monday, January 21, 2019 6:04 AM
  •  Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same. And, if you have any further query do let us know.

    Tuesday, February 5, 2019 9:29 AM