none
does visual studio2005 code runs on Framework 1.1? RRS feed

  • Question

  • I have developed my code using visual studio 2005.
    Now when i copy the exe of my code to another machine which has dotnet framework 1.1 installed on it, it is giving me an another.
    Does this error is beacuse of using dotnet framework 1.1?
    Do i need to install dotnet framework 2.0?



    Friday, October 23, 2009 11:26 AM

Answers


  • Visual Studio 2005 is targeted for .NET 2.0 and higher version development only.

    When you develop any application, by default it will be in 2.0. Yes, you have to install .NET Framework 2.0 in other machines.

    If you want to develop application in .NET 1.1 in VS 2005, try this msdn blog link:

    http://blogs.msdn.com/jomo_fisher/archive/2005/04/22/410903.aspx


    Regards,
    Jai

    • Marked as answer by YiChun Chen Friday, October 30, 2009 4:19 AM
    Friday, October 23, 2009 3:19 PM
  • Hi Anupam1234,

    Thank you for your post.

    By default, the target version of .NET Framework in Visual Studio 2005 is .NET Framework 2.0. Visual Studio 2005 was designed for .NET Framework 2.0. To deploy Visual Studio 2005 applications, the .NET Framework 2.0 must be installed on the target machine, before you install the deployment project.
    To apply your application on the target machine, please install .NET 2.0 to support it.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, October 30, 2009 4:19 AM
    Monday, October 26, 2009 9:33 AM

All replies

  • can anyone help me on this?its urgent.
    Friday, October 23, 2009 12:28 PM

  • Visual Studio 2005 is targeted for .NET 2.0 and higher version development only.

    When you develop any application, by default it will be in 2.0. Yes, you have to install .NET Framework 2.0 in other machines.

    If you want to develop application in .NET 1.1 in VS 2005, try this msdn blog link:

    http://blogs.msdn.com/jomo_fisher/archive/2005/04/22/410903.aspx


    Regards,
    Jai

    • Marked as answer by YiChun Chen Friday, October 30, 2009 4:19 AM
    Friday, October 23, 2009 3:19 PM
  • Hi Anupam1234,

    Thank you for your post.

    By default, the target version of .NET Framework in Visual Studio 2005 is .NET Framework 2.0. Visual Studio 2005 was designed for .NET Framework 2.0. To deploy Visual Studio 2005 applications, the .NET Framework 2.0 must be installed on the target machine, before you install the deployment project.
    To apply your application on the target machine, please install .NET 2.0 to support it.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, October 30, 2009 4:19 AM
    Monday, October 26, 2009 9:33 AM