none
Excel 2010 under Citrix RRS feed

  • Question

  • I know this has surfaced before, but I'm hoping there are some other developers out there who have found the "magic bullet" for resolving random errors that occur in VBA under Citrix. Doing my very first piece of work for a new client, I immediately got hit by a random "1004 Application" error.

    Please chime in if you have any thoughts on the matter.

    Link to a horror story

    Wednesday, August 27, 2014 4:16 PM

All replies

  • Believe it or not, I've now witnessed the same situation with Excel running in a virtualized MS Server 2012 environment. It appears the virtualization may be the common thread here.
    Thursday, August 28, 2014 1:09 PM
  • Hi Syswizard,

    I'm trying to involve some senior engineers into this issue and it will take some time. Your patience will be greatly appreciated.

    Sorry for any inconvenience and have a nice day!

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, September 3, 2014 1:44 AM
    Moderator
  • Thanks Fei.

    Once again, the situation is one where the VBA code interpreter trips-up when running unattended.
    But if you step thru the same code with the debugger, it interpretes all statements without error.

    My feeling is that it is a p-code threading issue.

    Wednesday, September 3, 2014 7:27 PM