none
AddDelegate - The specified object was not found in the store RRS feed

  • Question

  • Hi, 

    I'm getting this exception message when using the AddDelegate web service operation in Exchange 2007. 

    This is my AddDelegate request

     

     

    <t:RequestServerVersion Version="Exchange2007_SP1"/></SOAP-ENV:Header><SOAP-ENV:Body>
    <AddDelegate xmlns="http://schemas.microsoft.com/exchange/services/2006/messages">
    	<Mailbox>
    		<t:EmailAddress>user2@email.com</t:EmailAddress>
    	</Mailbox>
    	<DelegateUsers>
    		<t:DelegateUser>
    			<t:UserId>
    				<t:PrimarySmtpAddress>user1@email.com</t:PrimarySmtpAddress>
    			</t:UserId>
    			<t:DelegatePermissions>
    				<t:CalendarFolderPermissionLevel>Author</t:CalendarFolderPermissionLevel>
    			</t:DelegatePermissions>
    			<t:ReceiveCopiesOfMeetingMessages>false</t:ReceiveCopiesOfMeetingMessages>
    			<t:ViewPrivateItems>false</t:ViewPrivateItems>
    		</t:DelegateUser>
    	</DelegateUsers>
    <DeliverMeetingRequests>DelegatesAndMe</DeliverMeetingRequests>
    </AddDelegate>
    </SOAP-ENV:Body></SOAP-ENV:Envelope>
    

     


    This did work briefly for me however when i tested with a variety of email addresses in the first email element above it stopped working.

    ***Update*** Ok the AddDelegate method now seems to work, but when i try to create an item using the CreateItem operation i get the same error message. 

    Do i need to include any explicit inherit code to the CreateItem request. Some people have recommmended InheritanceType: All but i dont know if this can be placed in this particular request

     

    This is the workflow of my logic;

    1. Call the EWS connection using user1 email

    2. Call the EWS delegate operation adding user2 permissions to user1 delegate

    3. Call the EWS createItem operation using the user2 email address inside the SavedItemFolderId element

    Do i need to login again with user1 once i have successfully achieved delegate access?

    Any suggestions?




    • Edited by colinduggan Tuesday, October 18, 2011 10:55 AM
    Tuesday, October 18, 2011 9:52 AM

Answers

  • my problem with the AddDelegate method was down to how i was using the principle email and the delegates email. I had them in the wrong order. Once i placed the email addresses in the correct place it worked
    • Edited by colinduggan Tuesday, October 18, 2011 7:12 PM
    • Marked as answer by colinduggan Tuesday, October 18, 2011 7:12 PM
    Tuesday, October 18, 2011 7:11 PM