locked
[UWP] - Toast notification launch arguments missing RRS feed

  • Question

  • I have a windows 8 app, notifications enabled for my app. and its working great in windows 8 and windows 8.1 and Windows 10 machines.

    The only problem i am facing is when user taps on toast notification based on the launch arguments (which are present in toast can be read from LaunchActivatedEventArgs of Onlaunched event) I am redirecting the user to specific page. This functionality is working fine in Windows 8,8.1 machines but not working in windows 10 machine. Could you please suggest me what should i do ?


    suresh


    • Edited by Dev_SSC Thursday, August 20, 2015 12:04 PM
    Thursday, August 20, 2015 12:03 PM

Answers

  • Hello suresh,

    If I understand correctly, your scenario is that you build a UWP application with the toast notification to open your application and redirect to a specific page, if so, this is strange because I downloaded the official project named “Toast notifications sample”, it is a windows 8.1 sample originally, and I ported it to a UWP application, while it could work as expected, you could check the 5th scenario, its argument is "Content123". I also modified it to navigate to a specific page and it is successful. I suggest you could also have a try to see if this sample would work for you and if it works, you could check its source code and use it in your project.

    You could also share us with a repro demo project so that we could help make a test with it.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.





    Friday, August 21, 2015 7:03 AM

All replies

  • Hello suresh,

    If I understand correctly, your scenario is that you build a UWP application with the toast notification to open your application and redirect to a specific page, if so, this is strange because I downloaded the official project named “Toast notifications sample”, it is a windows 8.1 sample originally, and I ported it to a UWP application, while it could work as expected, you could check the 5th scenario, its argument is "Content123". I also modified it to navigate to a specific page and it is successful. I suggest you could also have a try to see if this sample would work for you and if it works, you could check its source code and use it in your project.

    You could also share us with a repro demo project so that we could help make a test with it.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.





    Friday, August 21, 2015 7:03 AM
  • @Fred Bao -  Thanks for postiing 

    suresh

    Friday, August 28, 2015 10:18 AM
  • You are running a Windows 8.0 (not 8.1) app on a Windows 10 machine, correct?

    Can you tell us exactly what's the issue when the toast is clicked? Which of the numbers below describe your issue?

    1. OnLaunched isn't being called?

    2. LaunchActivatedEventArgs is null?

    3. The Arguments property of LaunchActivatedEventArgs is null or empty?

    And also, does this happen only when the app is closed? Or all the time?




    • Edited by andrewbares7 Thursday, September 3, 2015 10:20 PM Asked for more info
    Thursday, September 3, 2015 9:59 PM