locked
Windows authentication works only with IP RRS feed

  • Question

  • User-2072441825 posted

    Windows authentication only works with IP though I tried with Bindings and updated hosts file.

    Any help would be appreciated.

    Saturday, February 28, 2015 1:51 PM

All replies

  • User753101303 posted

    Hi,

    With the name you are using, is the site in the "intranet zone" ?

    Saturday, February 28, 2015 2:10 PM
  • User-2072441825 posted

    I tried to add the domain *.domainname.com in intranet zone and in trusted sites, no respite.

    I have these bindings:

    10.46.2.75 testwinauth.domainname.com

    10.46.2.25 10.46.2.75

    I tried with only the first binding and both of them

    Changed authentication providers as well

    Authentication has been set to Windows and Impersonation to true.

    Saturday, February 28, 2015 2:44 PM
  • User753101303 posted

    Click on the page and use properties to see the zone. Don't add the site in both but only in Intranet Zone.

    What is the behavior you see? Some kind of error? If not, what if you show User.IsAuthencitated ?

    Saturday, February 28, 2015 3:51 PM
  • User-2072441825 posted

    I am being asked to enter username and password.

    If I use IP it does not ask me anything and takes windows NT login authentication.

    Saturday, February 28, 2015 4:40 PM
  • User753101303 posted

    And you are logged once done? For now you do have the expected behavior when the site is not part of the "intranet zone"' (by default Windows auth is enabled for "intranet sites" and disabled for "internet sites".

    So could you use http://support.microsoft.com/kb/2689449/en-us to show which zone is in use as suggested earlier and report back the result. I still think the site is not part of the "intranet zone".

    Saturday, February 28, 2015 5:57 PM
  • User-2072441825 posted

    Shows Zone as Intranet zone

    Saturday, February 28, 2015 6:26 PM
  • User753101303 posted

    And the server domain you are using is the same than your client machine and the client is currently connected to this domain (ie the session is not opened using cached domain logon information). This is the last thing I see.

    Sunday, March 1, 2015 4:48 AM
  • User-2072441825 posted

    In fact, I am trying to open the page from the server itself!

    Both server and client are in the same domain.

    Sunday, March 1, 2015 10:48 AM