Application pool problems on Windows 2008 R2


  • Hello,

    I try to install on 2 different servers the portal and server components and i've the same problem with the application pool, it's stop with the error:

    The identity of application pool WebsitePanel Server Pool is invalid. The user name or password that is specified for the identity may be incorrect, or the user may not have batch logon rights. If the identity is not corrected, the application pool will be disabled when the application pool receives its first request. If batch logon rights are causing the problem, the identity in the IIS

    I've used the default settings for the user (and use a local user or domain user), same issue on both servers and for all websitepanel components :(


    Any idea ?


    Saturday, January 15, 2011 2:06 PM

All replies

  • I have the same problem did you get a fix?
    Alan Mosley ThatsIT Solutions Web Development
    Thursday, September 29, 2011 6:22 PM
  • Make sure that websitepanel server application pool runs as WPserver identity and also make sure that you have not change password of this user.
    • Proposed as answer by Kailash Aghera Friday, September 30, 2011 3:53 AM
    Friday, September 30, 2011 3:53 AM
  • I found in event log that user did nnot have "log on as batch" permissions, add added all 3 wp users as well as IIS_IUSRS and it worked.

    all works except, when i add a server then try to add website it get an error

    Error: The configuration section 'system.webServer/management/delegation' cannot be read because it is missing a section declaration

    I tried adding it but still no good.

    can you post your application.config, just the relivent section so i can see the difference?

    here is mine

                <authentication defaultProvider="ConfigurationAuthenticationProvider">
                        <add name="ConfigurationAuthenticationProvider" type="Microsoft.Web.Management.Server.ConfigurationAuthenticationProvider, Microsoft.Web.Management, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
                <authorization defaultProvider="ConfigurationAuthorizationProvider">
                        <add name="ConfigurationAuthorizationProvider" type="Microsoft.Web.Management.Server.ConfigurationAuthorizationProvider, Microsoft.Web.Management, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
                <trustedProviders allowUntrustedProviders="false">
                    <add type="System.Web.Security.SqlMembershipProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                    <add type="System.Web.Security.SqlRoleProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                    <add type="System.Web.Security.WindowsTokenRoleProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />


    Alan Mosley ThatsIT Solutions Web Development
    Friday, September 30, 2011 4:23 AM
  • Ok fixed this problem as well, while trying to fix the first problem i changed app pool to allow 32bit, changed it back and all ok
    Alan Mosley ThatsIT Solutions Web Development
    Friday, September 30, 2011 4:30 AM