none
WEC7: SD-card not seen after latest update RRS feed

  • Question

  • I updated to the latest WEC7 release (October 2013, from July 2013) and now my SD-card does not work anymore. Are there any known issues with the SD-card driver?

    After installing the update my code did not compile anymore, as one of the function prototypes was changed, so I have the impression that something has been changed in the SD-card driver. After changing the prototype of the code compiled again, but it is not activated anymore.

    The changed file is public\common\ddk\inc\sdcardddk.h, from:
    typedef VOID (*PSD_IO_DISCONNECT_INTERRUPT) (SD_DEVICE_HANDLE);
    to:
    typedef SD_API_STATUS (*PSD_IO_DISCONNECT_INTERRUPT) (SD_DEVICE_HANDLE);

    BTW: Platform is Intel Atom, based on the Intel Crown Bay platform. The SD-card driver is part of the PCH EG20T driver package.

    Friday, November 29, 2013 8:51 AM

All replies

  • Hi,

      Are you sure about update date?! Is it _october2013_ exactly?

    I haven't seen any SDcard update at this update description -
    http://www.microsoft.com/en-us/download/details.aspx?id=41144

    Wednesday, December 4, 2013 9:21 AM
  • Yes, it is October 2013. I also checked the change log and there is no mention, also not in the releases before October. So I was really surprised by the fact that it stopped working.
    Wednesday, December 4, 2013 1:23 PM
  • I can confirm seeing changes in this and related files though I am not sure when it was introduced. I tried to clone the SDBus driver this week and saw that it wouldn't compile - the function prototype mentioned above had been changed and missing implementations to new function declarations within the same class were missing. Running a repair on my WEC7 installation fixed the issue.
    Friday, December 6, 2013 10:39 AM
  • Hello everybody,

    I ran into the same problem after the monthly update of October 2013.  I’m using the ATOME600 BSP from Adeneo BSP 3.1.0 and its included SD-Card driver.

    I tried to roll back to the September version after I read this article here. With the September-Update the SD-Driver interface is still ok and the driver works fine.

    After the clean installation of the platformbuilder I was able to compile my target without problems. When I updated to the latest version (October 2013) I had to choose “Power Management (minimal)” from the core OS services that was not necessary before.

    And I tried the approach to repair the October 2013 version. Still doesn’t work.

    Best Regards

    Chris

    Thursday, December 12, 2013 1:26 PM
  • For some reason the SD card driver in the Atom BSP is not compatible anymore. I got the advice from Adeneo to use the standard SD card driver instead of the one in the BSP.

    You should disable the SDBUSDRIVER (set SKIPBUILD=1 in SD_SDIO/SDBUSDRIVER/sources) and in SD_SDIO/SDHC/sources remove $(_PLATLIB)\$(_CPUDEPPATH)\SDbus.lib from SOURCELIBS and add $(_SYSGENOAKROOT)\lib\$(_CPUINDPATH)\SDBus.lib to TARGETLIBS.

    What I understood was that Intel more or less copied the MS version, but now MS changed it and Intel did not (yet).

    Tuesday, December 17, 2013 8:19 AM