locked
Supporting multiple applications on various .Net versions - WIF compatibility on VS2008 and VS2012 RRS feed

  • Question

  • User1784932228 posted

    I am supporting two different applications. One is a legacy app running on .Net 3.5 and we support it using VS2008. The other is a bit more modern, running .Net 4.5 on VS2012. 

    I need to change the legacy app to use claims-based identity authentication. If my dev box had VS2008 alone, it would require installation of WIF runtime and WIF SDK 3.5. However, since my box also has VS2012 installed, I dont seem to be able to install WIF (since its already part of .net 4.5).

    The reason I have not migrated the legacy project to use VS2012 is because it also uses EF 4.0 (or 4.1? the old one). I believe this is not compatible on VS2012. 

    Could anyone advise on the best way to support these application? And how should I implement WIF on the legacy application? (way to use VS2008?)

    Thanks

    Thursday, February 6, 2014 8:46 PM

Answers

  • User1784932228 posted

    Well what I ended up doing was just moving the older VS2008 project into VS2012. It seems there are no issues with the Entity Framework versions (so far at least). Will post here again if problems come up.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, February 10, 2014 5:39 PM

All replies

  • User-1106109124 posted

    Did you try to uninstall VS2012 then install WIF SDK 3.5 then go back and install VS2012?

    Saturday, February 8, 2014 11:05 PM
  • User1784932228 posted

    Well what I ended up doing was just moving the older VS2008 project into VS2012. It seems there are no issues with the Entity Framework versions (so far at least). Will post here again if problems come up.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, February 10, 2014 5:39 PM