The following forum(s) have migrated to Microsoft Q&A (Preview): Developing Universal Windows apps!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
[localized Issues]The Marketplace is not showing the localized application title RRS feed

All replies

  • What do you have for 'Title=' in your WMAppManifest.xml?


    -Eric.

    Thursday, April 18, 2013 9:38 PM
  • Hi Eric,

    This is my title setting in WMAppManifest.xml,

    <App xmlns="" ProductID="{xxx}" Title="@AppResLib.dll,-100" RuntimeType="Silverlight" Version="1.0.0.0" Genre="apps.normal" Author="xxxxxxxxxxxx" Description="Sample description" Publisher="xxxxxx" PublisherID="{xxxxxxxxx}">

      <PrimaryToken TokenID="xxxx" TaskName="_default">
            <TemplateFlip>
              <SmallImageURI IsRelative="true" IsResource="false">Assets/Tiles/S_Electrify.png</SmallImageURI>
              <Count>0</Count>
              <BackgroundImageURI IsRelative="true" IsResource="false">Assets/Tiles/M_Electrify.png</BackgroundImageURI>
              <Title>@AppResLib.dll,-200</Title>
              <BackContent></BackContent>
              <BackBackgroundImageURI></BackBackgroundImageURI>
              <BackTitle></BackTitle>
              <LargeBackgroundImageURI IsRelative="true" IsResource="false">Assets/Tiles/B_High.png</LargeBackgroundImageURI>
              <LargeBackContent />
              <LargeBackBackgroundImageURI IsRelative="true" IsResource="false"></LargeBackBackgroundImageURI>
              <DeviceLockImageURI IsRelative="true" IsResource="false">Assets/Tiles/S_Electrify.png</DeviceLockImageURI>
              <HasLarge>True</HasLarge>
            </TemplateFlip>
          </PrimaryToken>

    Thursday, April 18, 2013 11:35 PM
  • That looks correct to me.

    So, if I understand correctly, the Marketplace Detail page is showing the culture neutral application title, but only for culture Zh-CN. 

    Is that correct?

    Is this the first version of the application you uploaded? 

    If not, do you recall if your originally submitted XAP file had the correct title localization?


    -Eric.


    • Edited by Eric Fleck Tuesday, April 23, 2013 10:15 PM
    Tuesday, April 23, 2013 9:29 PM
  • Hi Eric,

    To answer yourfirst question.
    Yes,we madeSimplifiedChinese(zh-cn),and Traditional Chinese(zh-tw)localizedtitle.

    As forthesecond question.
    No, this the fifth version I uploaded, and my originally submitted XAP file had not correct title localization, Until the fourth version I Add to correct title localization.

    Thursday, April 25, 2013 1:55 AM
  • ... my originally submitted XAP file had not correct title localization, Until the fourth version I Add to correct title localization.


    I suspect this may be the problem...  I'll need to check but it's possible that the title used in the Store is not changed when updating a published app.

    -Eric.

    Thursday, April 25, 2013 1:30 PM
  • Oh! Waiting for your good news, thank you for the help.

    William

    Thursday, April 25, 2013 1:44 PM
  • William,

      For test purposes...
      Can you try a submitting your most recent XAP as a new application and see if the resulting detail page shows the correctly localized title?

      You can set the distribution channel to Beta in the first step of the submission ... expand the "More options" section at the bottom of the page, select the "Beta" radio button, and enter one or more Microsoft accounts that you want to allow to install the app.  (At least enter your own Microsoft account email address.)


    -Eric.

    Thursday, May 16, 2013 1:57 PM