none
Error in compiling: SignTool Error: No certificates were found that met all the given criteria.

    Question

  • I am moving from Visual Studio 2013 to Visual Studio 2017 (community). I have a couple of programs I developed in 2013 and have tried compile them in 2017 and get the following error:

    SignTool Error: No certificates were found that met all the given criteria.

    These would compile no problem in 2013 so what am I doing wrong?

    Wednesday, March 08, 2017 5:43 PM

Answers

  • Hi and thanks for the reply.  I kind of resolved the issue on my own.  Here is what I did to transfer over to 2017 and what I did to resolve the issue.

    The type of project was a Visual Basic - Windows Forms Application.  This was built using Visual Studio Express 2013.

    I use cloud storage to hold my projects so that I can work on them from my desktop or my laptop and have the current version to work on.  I installed Visual Studio 2017 community on my Laptop (keeping Visual Studio 2013 Express on my desktop). 

    In order to make sure that I don't screw-up this project I made a complete copy of the project folder under a Visual Studio 2017 folder and started to work in that folder.  This also copied the Certificate as that is in the project folder.

    I then started to work on VS 2017 on my laptop.

    When I got that error I went to the folder that held the certificate and double clicked it but for some reason it would not install (it actually opened in a notepad type of window).  I know that sounds weird but that is what happened.

    So what I did was I moved the certificate to the desktop (for safe keeping).  I then opened the project in VS 2017 and deleted the certificate from the Solution Explorer Window.  I then went to the Project > Properties > Signing window and checked the "Sign the Assembly" checkbox and signed it.  I left the "Sign the ClickOnce Manifests" checkbox checked.

    This installed a new temp certificate and I can now work on this project in 2017 on my laptop.  I can now start testing to see how 2017 works and see if I want to move to this version.

    • Marked as answer by TJBlues Friday, March 10, 2017 7:56 PM
    Friday, March 10, 2017 7:39 PM

All replies

  • Hi TJBlues,

    Please share me which type project you have created?

    1). First we could uncheck the following options in project properties panel. Refer to this screenshot:

    2). We need to install the certificate, please find the xxx.pfx file in your project, and doubt-click to install it.

    The similar issue as yours, you could refer to it:

    http://stackoverflow.com/questions/22946399/signtool-error-no-certificates-were-found-that-met-all-given-criteria-with-a-wi

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, March 10, 2017 5:32 AM
    Moderator
  • Hi and thanks for the reply.  I kind of resolved the issue on my own.  Here is what I did to transfer over to 2017 and what I did to resolve the issue.

    The type of project was a Visual Basic - Windows Forms Application.  This was built using Visual Studio Express 2013.

    I use cloud storage to hold my projects so that I can work on them from my desktop or my laptop and have the current version to work on.  I installed Visual Studio 2017 community on my Laptop (keeping Visual Studio 2013 Express on my desktop). 

    In order to make sure that I don't screw-up this project I made a complete copy of the project folder under a Visual Studio 2017 folder and started to work in that folder.  This also copied the Certificate as that is in the project folder.

    I then started to work on VS 2017 on my laptop.

    When I got that error I went to the folder that held the certificate and double clicked it but for some reason it would not install (it actually opened in a notepad type of window).  I know that sounds weird but that is what happened.

    So what I did was I moved the certificate to the desktop (for safe keeping).  I then opened the project in VS 2017 and deleted the certificate from the Solution Explorer Window.  I then went to the Project > Properties > Signing window and checked the "Sign the Assembly" checkbox and signed it.  I left the "Sign the ClickOnce Manifests" checkbox checked.

    This installed a new temp certificate and I can now work on this project in 2017 on my laptop.  I can now start testing to see how 2017 works and see if I want to move to this version.

    • Marked as answer by TJBlues Friday, March 10, 2017 7:56 PM
    Friday, March 10, 2017 7:39 PM
  • Hi friend,

    Glad to know you have resolved your issue, and share the solution here, which could be helpful for others who have the same issue.

    Thank you very much.

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 13, 2017 9:54 AM
    Moderator
  • Thanks This worked for me. 
    Monday, October 23, 2017 4:23 PM