locked
A .NET Developer Primer for Single-Page Applications RRS feed

  • Question

  • User1366720210 posted

    I was wondering if someone is familiar with this article. I need some help with it. I am running the provided code but not getting any data shown. Would appreciate if somebody could help me.

    http://msdn.microsoft.com/en-us/magazine/dn605877.aspx

    Thanks

    Tuesday, March 25, 2014 10:31 AM

Answers

  • User-821857111 posted

    It has a backup file (.bak) and an install script, and the connection string points to localhost. It will work out of the box if you have Northwind already installed on a default (not named) instance of SQL Server (not SQL Server Express).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, March 26, 2014 8:56 AM

All replies

  • User-821857111 posted

    You need to install the Northwind database and make sure the connection string in the web.config is pointing to the right location. If you don't already have Northwind installed on your SQL Server, open the instnwnd.sql file in SQL Server Management Studio and click the Execute button. 

    If you ever have problems getting AJAX-based apps to work, you can use the built-in developer tools within your chosen browser to see what's going on. The Network tab usually shows the AJAX request being made and the response - including Internal Server errors.

    Wednesday, March 26, 2014 4:01 AM
  • User1366720210 posted

    I have Northwind database installed but will verify the connection string. But I thought the source code that comes with the article was fully functional because it has a db file.

    Wednesday, March 26, 2014 8:06 AM
  • User-821857111 posted

    It has a backup file (.bak) and an install script, and the connection string points to localhost. It will work out of the box if you have Northwind already installed on a default (not named) instance of SQL Server (not SQL Server Express).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, March 26, 2014 8:56 AM
  • User1366720210 posted

    Yes it was a problem with a connection string. As you have pointed out it was looking for a unnamed instance while I have a named one. Thanks for the help.

    Now, I want to take one step further. I want to use a different UI library altogether. Where whould I start?

    Wednesday, March 26, 2014 10:53 AM
  • User-821857111 posted

    Where whould I start?
    AngularJS perhaps? 

    http://angularjs.org/

    Wednesday, March 26, 2014 11:04 AM
  • User1366720210 posted

    Well, no, that is not what I meant. I am thinking to use a pure UI library, not another framework with UIs. I have been looking into DHTLX as a set of nice looking UI controls. Am I thinking it all wrong?

    Wednesday, March 26, 2014 11:14 AM
  • User-821857111 posted

    Am I thinking it all wrong?

    Probably not. I am not that familiar with the SPA frameworks.

    Wednesday, March 26, 2014 11:41 AM