locked
web address change automatically RRS feed

  • Question

  • User-1330485181 posted

    Hi All,

    I made a web based program using ASP.NET C# 2010 and I have 2 website on the web server 2003 with IP eg. 10.1.1.9. The first website is using port 80 and the second website using port 81. 

    If I want to access the second website, in the browser I typed

    http://10.1.1.9:81/index.aspx   , it runs well for several months, but now when I type http://10.1.1.9:81/index.aspx , It displays like this : 

    http://10.1.1.9:81/(S(403gfn2prwaq4quykkffpiue))/index.aspx

    We can login and open the menu, but If I access the web from the internet eg http://erp.xxx.com:81/index.aspx It displays an error.

    Does anyone know how to solve this problem ?

    Thank you

    Regards,

    Sentoso Bunyamin

    Friday, October 17, 2014 8:02 AM

Answers

  • User-760709272 posted

    You have cookieless sessions enabled somehow.  Look at the config settings, or try different browses as there was (now patched I think) a bug in IE10 that caused .net to serve cookieless sessions.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, October 17, 2014 8:10 AM
  • User-1330485181 posted

    Thank you Angie Xu for the explantion, the problem solved already.

    After I check the web config there is a line : <sessionState mode="InProc" cookieless="true" timeout="99999"/> . This line cause the web address changed automatically.

    Thank you very much.

    Best Regards,

    Sentoso

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, October 20, 2014 12:18 AM

All replies

  • User-760709272 posted

    You have cookieless sessions enabled somehow.  Look at the config settings, or try different browses as there was (now patched I think) a bug in IE10 that caused .net to serve cookieless sessions.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, October 17, 2014 8:10 AM
  • User-1330485181 posted

    You have cookieless sessions enabled somehow.  Look at the config settings, or try different browses as there was (now patched I think) a bug in IE10 that caused .net to serve cookieless sessions.

    I am not using IE10,  I use Firefox 32.0.3 to browse my web site. I try to used Google Chrome Browser, I also get the same result, the web address changed.

    Friday, October 17, 2014 8:25 AM
  • User-166373564 posted

    HI Sentoso,

    It seems that there are url rewrite rules in your web.config file, please check it. If it still has same issue, please feel free to post back with detailed error message.

    Best regards,

    Angie 

    Sunday, October 19, 2014 11:27 PM
  • User-1330485181 posted

    Thank you Angie Xu for the explantion, the problem solved already.

    After I check the web config there is a line : <sessionState mode="InProc" cookieless="true" timeout="99999"/> . This line cause the web address changed automatically.

    Thank you very much.

    Best Regards,

    Sentoso

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, October 20, 2014 12:18 AM
  • User-760709272 posted

    You have cookieless sessions enabled somehow.

    After I check the web config there is a line : <sessionState mode="InProc" cookieless="true" timeout="99999"/> .

    You're welcome.

    Monday, October 20, 2014 4:23 AM