manifest problem


  • Hi,

    I have problem with services, especialy with manifest. I am trying to write my first program on Lego NXT and I am writing almost identical code to Robotic Tutorial 2. The robot should drive when I press touch sensor and stop driving when I press it again. The problem is when i run my application the robot make sound that he is connected and the program started but when I press touchsensor nothing happens. I can see that service is running and everything is ok via browser - it responses to states of bumper. I can see that it detects pressed bumper but motors are not running.

    What is more the breakpoints are not working (they are working in robotic tutorial code but not in mine).

    What I realized: robotic tutorial works perfect with this manifest (and the second one more advanced):

    <?xml version="1.0" ?>
      <!-- Robotics Tutorial 2 manifest requires a hardware manifest.                   -->
      <!-- When you start this manifest, also include one of the following:             -->
      <!--                                                                              -->
      <!--    -m:"samples\config\LEGO.NXT.MotorTouchSensor.manifest.xml"                -->
      <!--    -m:"samples\config\FischerTechnik.MotorTouchSensor.manifest.xml"          -->
      <!--                                                                              -->
        <!--Start tutorial 2-->

    Could someone explain me what for is this manifest? And why when i create manifests with Manifest Editor I do not get this one, but only this more advanced and some config files?

    Thanks in advance
    Adam Jablonski

    Monday, March 29, 2010 7:40 PM


  • Ok. Problem solved. It was easier than it seemed :). This manifest connects tutorial service with services witch are responsible for motors, touch sensor etc. I opend it in manifest editor and what I saw there, explained everything :D

    Wednesday, March 31, 2010 2:25 PM