locked
Windows Phone Emulator Internal Switch no IP adresss RRS feed

  • Question

  • Hi,

    I've been struggling with getting the Windows Phone 8 emulator to work for few weeks now and nothing seems to work. My issue is that the Windows Phone Emulator Internal Switch never gets an IP address when the DHCP is enabled.

    I've tried to use the WIFI the the cable connection. I've even disabled the WIFI. In normal settings in our network, we use MAC address reservation for DHCP. But that is only for the WIFI. I even temporally removed the reservation, but it still didn't work. I simply don't get any IP address to the Windows Phone Emulator Internal Switch. 

    If I manually set the IP address to 169.254 something, like 169.254.80.80, the emulator works, but obviously without any internet connectivity. Setting manually an IP address which would work in our network, doesn't work. If I do that, for some reason VS can't connect with the emulator.

    I've even reinstalled Windows 8 and the Windows Phone 8 SDK, but that didn't help either. The computer is a HP ProBook 4730s and I'm not running any VPN stuff on it.

    Could someone please help me? I've running out of ideas and I can't find anything that works for me even from Google!

    Thanks :)

    Monday, December 10, 2012 9:06 AM

Answers

  • Hi,

    Try this. At least worked for me after 2 days.

    Visual studio 2012 creates two switches 

    1)Windows Phone Emulator Internal switch 

    2) External Virtual switch

    Control Panel\Network and Internet\Network Connections

    1) LAN adapter is already there on your machine.

    Go to -> Properties

    Make sure Hyper v extensible virtual switch is enabled.

    2) Go to External Virtual Switch -> Properties.

    Go to Sharing tab -> Tick first option

    Allow other network users to connect through this computer's Internet connection

    Do not tick second option

    Uncheck IPv6 while keeping all other settings as it is

    In IPv4 insert DNS and alternate DNs address 

    3)  Go to Internal Virtual Switch ->Properties

    Uncheck IPv6 while keeping all other settings as it is


    • Edited by Manmath Kulkarni Wednesday, December 12, 2012 11:13 AM
    • Proposed as answer by Manmath Kulkarni Wednesday, December 12, 2012 12:05 PM
    • Marked as answer by Sasler0 Wednesday, December 12, 2012 1:35 PM
    Wednesday, December 12, 2012 11:12 AM
  • Another update:

    It works now! I'm not 100% sure how I got it to work, but it does seem to work now. :)

    Basically I switched on internet sharing as suggested by Manmath Kulkarni. Then I went to change the IP address to 169.254.. something. At first the internet didn't seem to work, but after going back to 192.168.137.1 and then back again to 169.254... (169.254.137.1 to be precise) it started working. 

    I really don't know why it needs the 169.254... address, but the main thing is that it works now.

    Thank you again for all your help. :0

    • Marked as answer by Sasler0 Wednesday, December 12, 2012 1:43 PM
    Wednesday, December 12, 2012 1:43 PM

All replies

  • Hi ,

    Following link has information about troubleshooting Emulator settings. Can you please let us know if you have looked into the following information and if it helps to resolve the issue?

    http://msdn.microsoft.com/en-us/library/windowsphone/develop/jj681694(v=vs.105).aspx

    Tuesday, December 11, 2012 6:52 PM
    Moderator
  • Hi ,

    Following link has information about troubleshooting Emulator settings. Can you please let us know if you have looked into the following information and if it helps to resolve the issue?

    http://msdn.microsoft.com/en-us/library/windowsphone/develop/jj681694(v=vs.105).aspx


    Yes, I've looked at that already, but nothing helped. Thanks anyway. :)
    Tuesday, December 11, 2012 6:54 PM
  • Hello try to do this

    IE internet options -> connections tab -> LAN settings -> uncheck all boxes

    Then close the emulator and reopen it

    and try to use DHCP not static one

    Tuesday, December 11, 2012 8:33 PM
  • Hello try to do this

    IE internet options -> connections tab -> LAN settings -> uncheck all boxes

    Then close the emulator and reopen it

    and try to use DHCP not static one

    No, disabling Proxy setting didn't work either.

    I simply won't get an IP address from the DHCP. Is there a way to use a static address?

    Thanks :)

    Wednesday, December 12, 2012 8:24 AM
  • Also, could anyone please tell me if you are getting an IP address from DHCP. What I've understood about Hyper-V Internal Virtual Network is that it should be able to communicate outside the host. Is there something I've missed?

    BTW, I had to create the Windows Phone Emulator Internal Switch manually, since when VS2012 tries to do it, I get the "Xde couldn't find an IPv4 address for the host machine" error and the Windows Phone Emulator Internal Switch gets removed.

    Wednesday, December 12, 2012 8:42 AM
  • Hi,

    Try this. At least worked for me after 2 days.

    Visual studio 2012 creates two switches 

    1)Windows Phone Emulator Internal switch 

    2) External Virtual switch

    Control Panel\Network and Internet\Network Connections

    1) LAN adapter is already there on your machine.

    Go to -> Properties

    Make sure Hyper v extensible virtual switch is enabled.

    2) Go to External Virtual Switch -> Properties.

    Go to Sharing tab -> Tick first option

    Allow other network users to connect through this computer's Internet connection

    Do not tick second option

    Uncheck IPv6 while keeping all other settings as it is

    In IPv4 insert DNS and alternate DNs address 

    3)  Go to Internal Virtual Switch ->Properties

    Uncheck IPv6 while keeping all other settings as it is


    • Edited by Manmath Kulkarni Wednesday, December 12, 2012 11:13 AM
    • Proposed as answer by Manmath Kulkarni Wednesday, December 12, 2012 12:05 PM
    • Marked as answer by Sasler0 Wednesday, December 12, 2012 1:35 PM
    Wednesday, December 12, 2012 11:12 AM
  • Hi,

    did you also consider all the hints given on this blog:

    http://igrali.com/2012/10/31/windows-phone-8-emulator-wasnt-able-to-create-the-virtual-machine/ 

    Can you run other virtual machines and bind internal switches to those?

    If not I think this might be more a general HW or third party solution issue rather a WP emulator problem.

    Please see also here:

    http://h30434.www3.hp.com/t5/Notebook-Operating-Systems-e-g/HP-ProBook-4730s-BIOS-Cannot-enable-Virtualization-Technology-in/td-p/1030489 

    Please check if you have to most recent updates for this notebook installed:

    E.g. BIOS update F.29, ......(not listed under W8, for this select W7)

    http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=5060895&prodTypeId=321957&prodSeriesId=5060893&swLang=13&taskId=135&swEnvOID=4132 

    Please let us know.

    Best regards
    Klaus


    Klaus Bassler

    Wednesday, December 12, 2012 12:34 PM
    Moderator
  • Hi,

    Try this. At least worked for me after 2 days.

    Visual studio 2012 creates two switches 

    1)Windows Phone Emulator Internal switch 

    2) External Virtual switch

    Control Panel\Network and Internet\Network Connections

    1) LAN adapter is already there on your machine.

    Go to -> Properties

    Make sure Hyper v extensible virtual switch is enabled.

    2) Go to External Virtual Switch -> Properties.

    Go to Sharing tab -> Tick first option

    Allow other network users to connect through this computer's Internet connection

    Do not tick second option

    Uncheck IPv6 while keeping all other settings as it is

    In IPv4 insert DNS and alternate DNs address 

    3)  Go to Internal Virtual Switch ->Properties

    Uncheck IPv6 while keeping all other settings as it is


    Well this way I do at least get an IP address to the Windows Phone Emulator Internal Switch, but now I get the "Could not communicate" error and the emulator closes.

    The IP I get is 192.168.137.1. Do you have the same?

    Thanks :)

    Wednesday, December 12, 2012 12:50 PM
  • Yes, I've tried all those. Hyper-V seems to work fine and I got the latest BIOS and drivers.

    Again, could someone please tell me if you get an IP address to your Windows Phone Emulator Internal Switch and what is it? Is it a 169.254.. range? Or a 192.168..? Or do you get a regular IP address from the DHCP? I haven't been able to get an answer for this question.

    Thank you all for your help :)

    Wednesday, December 12, 2012 1:07 PM
  • OK, here is an update:

    With the solution provided by Manmath Kulkarni, I can get the internet to work on the emulator. However, VS2012 is unable to connect to the emulator and things like the Back and Home buttons don't work. The IP address for the Windows Phone Emulator Internal Switch is a static 192.168.137.1 which is automatically set when I turn on sharing on my external virtual network.

    If I manually change the the IP address to 169.254.. something, the VS2012 doesn't report any errors, the emulator woks well and the app I'm working on gets installed just fine. The only problem is that the internet doesn't work on the emulator.

    Does anyone have any idea where the problem could be?

    Thanks :)

    Wednesday, December 12, 2012 1:25 PM
  • Another update:

    It works now! I'm not 100% sure how I got it to work, but it does seem to work now. :)

    Basically I switched on internet sharing as suggested by Manmath Kulkarni. Then I went to change the IP address to 169.254.. something. At first the internet didn't seem to work, but after going back to 192.168.137.1 and then back again to 169.254... (169.254.137.1 to be precise) it started working. 

    I really don't know why it needs the 169.254... address, but the main thing is that it works now.

    Thank you again for all your help. :0

    • Marked as answer by Sasler0 Wednesday, December 12, 2012 1:43 PM
    Wednesday, December 12, 2012 1:43 PM
  • Hi,

    thank you for this upate.

    Yes, the Windows Phone Emulator Internal Switch always uses 169.254.XXX.XXX addresses since it uses a "link local" block.  As described in [RFC3927], "it is allocated for communication between hosts on a
       single link.  Hosts obtain these addresses by auto-configuration,   such as when a DHCP server cannot be found."

    So I think your Hyper-V was somehow messed up.

    Actually enabling sharing should not be required!
    However, it seems as with those troubleshooting steps the configuration somehow fixed itself.

    Right now it looks as there was something DHCP related.
    See also:

    Networking in the Windows Phone 8 Emulator
    http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff402563(v=vs.105).aspx 


    Best regards
    Klaus


    Klaus Bassler

    Wednesday, December 12, 2012 2:11 PM
    Moderator