locked
Permissions level on Publishing site RRS feed

  • Question

  • Each manager is responsible for adding content to their own site.  Content resides in a variety of webparts (content editor, Summary Links, List View).

    When I have given Full rights to a department subsite, managers have "broken" pieces, messed up links and images, and made changes to the uniform look of the site.  (We would like to have IT department review all "pages" for approval.)

    But if I reduce the rights to Contribute, they cannot change the text in Content Editor webparts or add/remove links from Summary Links webparts.  Design rights looks like it includes some Approve rights. 

    What combination of rights should I use to accomplish an ability to edit, add, but WITHOUT ability to APPROVE for PUBLISHING?

    Wednesday, October 19, 2011 9:01 PM

Answers

  • Hi,

    With regard to seetting up approval on the pages library go to the pages library settings versioning and click require approval. The pages library is created via the Publishing feature or Site Pages Library dependent on the type of site collection or site you have created.

    1. Navigate to the pages library (via "View All Site Content")
    2. On the library ribbon, choose "Library Settings"
    3. Open "Versioning Settings"
    4. Set "Content Approval" to Yes and click OK.

     

    The permission is used to grant permisions to specific users not to enable approval on your libraries and lists.

     

    -Ivan

     


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    • Edited by Ivan Sanders Friday, October 21, 2011 10:12 AM
    • Proposed as answer by Victor Chataboon Friday, October 21, 2011 2:13 PM
    • Marked as answer by orlandp Tuesday, October 25, 2011 9:34 PM
    Friday, October 21, 2011 10:11 AM

All replies

  • I would look at the Design permissions, print it out for reference. Then create a new permission level and have all of the permissions from Design and leave out the Approve Items option.

    It is not recommended to Edit the built in permissions.

     


    -victor

    Please remember to indicate if your question/comment has been answered.

    Wednesday, October 19, 2011 9:11 PM
  • Not sure how to create permission level to allow APPROVE list items, but require APPROVAL on pages:

    This is the standard permission level:  .  You can see that it includes approval for pages and list items.

    If I copy the permission level for an existing level, or create a new one, the only APPROVAL option I have appears under LIST PERMISSIONS, nothing appears under SITE PERMISSIONS indicating APPROVAL for PAGES.  . 

    I don't know which option allows for PAGE APPROVAL.

    Thursday, October 20, 2011 12:04 AM
  • I believe that option is the same, it may be a bug in the wording when you create a new permission level. It couldn't hurt to give it a shot and see if that solves your problem.

    -victor

    Please remember to indicate if your question/comment has been answered.

    Friday, October 21, 2011 2:34 AM
  • Hi,

    With regard to seetting up approval on the pages library go to the pages library settings versioning and click require approval. The pages library is created via the Publishing feature or Site Pages Library dependent on the type of site collection or site you have created.

    1. Navigate to the pages library (via "View All Site Content")
    2. On the library ribbon, choose "Library Settings"
    3. Open "Versioning Settings"
    4. Set "Content Approval" to Yes and click OK.

     

    The permission is used to grant permisions to specific users not to enable approval on your libraries and lists.

     

    -Ivan

     


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    • Edited by Ivan Sanders Friday, October 21, 2011 10:12 AM
    • Proposed as answer by Victor Chataboon Friday, October 21, 2011 2:13 PM
    • Marked as answer by orlandp Tuesday, October 25, 2011 9:34 PM
    Friday, October 21, 2011 10:11 AM
  • Did that already.  So guess I am good to go.  Thanks for the clarification.
    Tuesday, October 25, 2011 9:34 PM