locked
Cannot perform package validation in Win8 Consumer Preview (64bit)

    Question

  • Hi friends, I confronted a trouble in validating my Metro App.
    I chose "Store"/"Create Local Package" and launched Windows App Certification Kit.
    After successfully executed the PRELOG phase,
    I simply got "cannot continue testing since the specified Metro style App was not found...".
    But the package was created indeed, and the paths shown in output are correct...

    P.S. I used appcertui following the guide in MSDN, but just could not see my deployed apps for validation. Could this be the same issue?  

    Friday, March 30, 2012 3:19 AM

All replies

  • Strangely the validation is possible in a 32 bit Win8 CP machine...
    Sunday, April 1, 2012 8:26 AM
  • Hello,

    I think the package full name is incorrect. The package full name should be like this:

    Package Name_version_platform_PublisherId
    microsoft.sdksamples.fileaccesssample.cpp_1.0.0.0_x86__s9y1p3hwd5qda

    You can follow this sample codes to get the package full name
    App package information sample
    http://code.msdn.microsoft.com/windowsapps/Package-sample-46e239fa

    Best regards,
    Jesse


    Jesse Jiang [MSFT]
    MSDN Community Support | Feedback to us

    Monday, April 2, 2012 7:19 AM
  • Try these steps on the Consumer Preview system with the problem:

    1. Open a powershell window
    2. Do a “Get-AppxPackage > out.txt”
    3. Open out.txt and look at InstallLocation field of all the apps installed.
    4. For the apps whose InstallLocation is blank, do a “Remove-AppxPackage
      <packageFullName>”

    Then try to run thru the App Cert Kit again.



    David Lamb



    Wednesday, April 4, 2012 2:58 PM
    Moderator
  • Do you have auto-increment version number on? If so, turn it off, and set it the same as shown in Get-AppxPackage. (1.0.0.0, most likely)
    Thursday, April 5, 2012 12:55 AM
  • Originally I had it on, and then I turned this option off so that no suffix will be appended
    Thursday, April 5, 2012 12:59 AM