locked
visual studio 2012/13 Premium edition does it support vsix project RRS feed

  • Question

  • we are getting error for a vsix project compiled in 2015 to use in the 2013 premium edition. we enabled the supported versions while compiling in 2015 to profession, enterprise and ultimate. But since 2013 has premium version , the installation failed error is thrown when tried to install the solution
    Wednesday, January 17, 2018 11:07 AM

All replies

  • Hi PragnyaJay,

    If you use visual studio 2013 vsix project, you need to download and install visual studio 2013 sdk. For more information, please refer to:

    https://msdn.microsoft.com/en-us/library/bb166441.aspx

    #Download URL

    https://my.visualstudio.com/Downloads?q=visual%20studio%202013%20sdk

    Best regards,

    Zhanglong Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, January 19, 2018 7:11 AM
  • Not knowing the exact error message you are encountering, or what versions/editions of Visual Studio your .VSIX explicitly targets, makes it difficult to offer up any suggestions.

    Generally speaking, it's recommended that you create and build your extension (and VSIX deployment package) with the earliest version of Visual Studio you want to target.

    When posting questions like these, consider posting the exact error message encountered, and perhaps additional details about the .VSIX you are attempting to installed. Like what does the .vsixmanifest include, in particular the <Installation> portion of the .vsixmanifest.

    Sincerely,


    Ed Dore

    Tuesday, January 30, 2018 6:06 PM