none
SendNotifyMessage and WM_SETTINGCHANGE not working anymore? RRS feed

  • Question

  • https://social.msdn.microsoft.com/Forums/vstudio/de-DE/2be8b655-a3d3-4f75-8570-52ee33d6a57c/poblem-mit-policymanagement?forum=visualcsharpde

    Anyone got problems too with SendyNotify SendNotifyMessage(HWND_BROADCAST, WM_SETTINGCHANGE, 0, 0);

    I created an Applocker Rule app just like in the above link. These changes were pushed with the method RefreshPolicyEx and send to open processes with SendNotifyMessage. I cannot recall the exact date but this worked since day one but since a few weeks / months , open processes are no longer "receiving" or "handling" this event, as applocker rules are only applying when the explorer.exe processes are getting killed etc.

    Anyone experienced similar stuff? Is this a windows 10 bug or an wanted change by microsoft? I tried a thousand different ways to push my gpos to open processes (even iteraded all explorer.exe handles and send it directly) but nothing is working anymore.

    Tuesday, June 18, 2019 7:07 AM

All replies

  • Hi 

    Thank you for posting here.

    First, I think it is best for you to provide a English link instead of the other language link, because it is a English forum.

    Second, could you provide the code about your problem?

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, June 18, 2019 9:40 AM
    Moderator