locked
Loading solutions with web deployment projects always shows conversion wizard RRS feed

  • Question

  • User1205079068 posted

     Hello,

    when i load a  solution that contains one or more web deployment projects VS always shows me the project conversion wizard ("Projekt Konvertierungsassistent" in german, not sure how it is called in the english version). I mead the wizard that is shown when you load projects from an older VS version.

    When i look into the conversion report it tells me that nothing had to be converted!

    The problem is that this wizard sometimes completely hangs and VS has to be killed by the task manager. Furthermore this wizard creates the conversion log files in the solutions directory that have to be deleted manually. Quite anoying!

    Can anyone give me a hint how to get rid of that wizard when loading solutions with web deployment projects???

    Thanks in advance,

    Ralf

    Monday, June 15, 2009 3:49 AM

Answers

  • User372121194 posted

    Hi,

    What is your Visual Studio version and were the projects upgraded from older version?  Please make sure you are not using non-release version of Web Deployment project.

    If your solution was upgraded from older version, please make sure every project has been upgraded, including UNLOADED projects. You also can refer to Visual studio conversion wizard opens each time for converted 2008 solution.

    You also can create blank solution and then add projects to it. 

     

    I look forward to receiving your test results.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 18, 2009 3:54 AM

All replies

  • User372121194 posted

    Hi,

    What is your Visual Studio version and were the projects upgraded from older version?  Please make sure you are not using non-release version of Web Deployment project.

    If your solution was upgraded from older version, please make sure every project has been upgraded, including UNLOADED projects. You also can refer to Visual studio conversion wizard opens each time for converted 2008 solution.

    You also can create blank solution and then add projects to it. 

     

    I look forward to receiving your test results.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 18, 2009 3:54 AM
  • User1205079068 posted

    Hello,

    with the help of the link to the blog post you provided  i found out that the DevExpress Plugin "Refactor" was causing that behaviour! When i disable it for startup load, then the solution is loaded without showing the conversion wizard! After that i can load the DevvExpress tools manually.

    Thank you for the hint! (i will contact DevEx support and see if they can fix it)

    Ciao,

    Ralf

    Friday, June 19, 2009 3:07 AM
  • User1199339107 posted

    Hi,
    I get the same problem.
    how did you remove DevExpress from the startup and reactivate it after?

    Thanks in advance!

    Wednesday, July 29, 2009 2:01 PM
  • User1205079068 posted

    Hello,

    i have contacted DevEx support and they told me the following solution (works only if you do not need C++ support!!):

    Search for the DLL "DX_CppLanguage.dll" (can normally be found in "%ProgramFiles%\DevExpress\IDETools\System\DXCore\BIN\SYSTEM". Delete this DLL, or better rename it to "CppLanguage.BAK"

    After that change you can load solutions with web deployment projects without the conversion wizard. (for me that solution works like a charm)

    Background: it seems to be a bug in VisualStudio. Everytime an addin calls "DTE.GetObject("VCProjects")" the wizard is shown and this is called inside the dll "DX_CppLanguage.dll". So if you do net need C++ support with the DevExpress addin, try it!

    Ciao,

    Ralf

    Wednesday, July 29, 2009 3:08 PM
  • User1199339107 posted

    Thanks for the tip, but in my case, it doesn't work :(

    I'm little clueless about this, because I'm the only developer in my team to get that which is stange. Other people with DevExpress working normally don't have this issue.

    Thursday, July 30, 2009 7:35 AM