locked
VS 2012 Lightswitch Form auth + MySQL RRS feed

  • Question

  • Hello folks,

    I'm currently experiencing a problem which I'm not 100% certain about the part which is making the troubke, so I'm just gonna tell you guys what I'm trying to do and actually doing.

    Its about trying and more or less failing by deploying a Lightswitch desktop application (local) with form authentication using MySQL

    1.) Create a new Lightswith app in VS 2012 with integrated Lightswitch

    2.) Selecting the DB Source with the connection wizard to my root servers MySQL

    3.) Importing the tables etc.

    4.) Creating some screens

    5.) Trying to deploy everything, works fine until it comes to provding the database connection for probably creating the authentication data - cause there's simply no MySQL Connector to select

    .. that's where I stuck.

    It seems like when I remove the form authentication everything's working fine.
    Any Ideas?

    Is the form authentication in Lightswitch with the use of MySQL simple not supported or is that a problem with the .NET Connector itself?

    ~regards skizer

    Tuesday, March 19, 2013 4:54 PM

Answers

  • Hi skizer,

    To use forms authentication or windows authentication, you have to make sure that you host the data on SQL server. You can still have your MySQL data source attached to your application.

    Thanks

    Rohit

    • Proposed as answer by OptikSageModerator Wednesday, March 20, 2013 10:21 PM
    • Marked as answer by skizer Thursday, March 21, 2013 1:45 PM
    Wednesday, March 20, 2013 9:59 PM

All replies

  • Hi skizer,

    To use forms authentication or windows authentication, you have to make sure that you host the data on SQL server. You can still have your MySQL data source attached to your application.

    Thanks

    Rohit

    • Proposed as answer by OptikSageModerator Wednesday, March 20, 2013 10:21 PM
    • Marked as answer by skizer Thursday, March 21, 2013 1:45 PM
    Wednesday, March 20, 2013 9:59 PM
  • Also, be aware that there is a bug with the version of the Publish Wizard that shipped with VS 2012 where if you only use attached datasources, you are not prompted for the connection string info for the SQL database used to store the authentication tables (if you do a Package publish).

    The latest version of the publish wizard can be downloaded with the latest Azure SDK:

    http://go.microsoft.com/fwlink/?LinkId=254364&clcid=0x409


    David Kidder | Senior SDET | Microsoft | LightSwitch

    Thursday, March 21, 2013 12:46 AM
    Moderator
  • Hello,

    thanks for the answer guys - I almost expected it ..
    @Dave Kidder, also thanks for the additional info!

    Thursday, March 21, 2013 1:46 PM